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Introduction

Whenever you need to enter text, to place pictures or create graphic elements
you will need to create objects. Objects may be modified after they are cre-
ated, their form, position, type, color and other object properties can all be
modified.

This chapter will show you how to create and modify objects. Even if you are
familiar with other illustration or layout programs we advise you to read this
chapter carefully since it will give you in-depth information on the sometimes
unique possibilities of Viva products.

The Toolbar
Through the Toolbar you are able to create new or modify existing objects.
The following tools are available from the Toolbar:

- Rectangle tool (Text, Picture and Graphic Objects)

- Ellipse tool (Text, Picture and Graphic Objects)

- Polygon tool (Text, Picture and Graphic Objects)

- Line tool

- Orthogonal Line tool

- Multiple line tool

Other objects like for instance Bézier objects or Bézier curves, circular objects
etc. can be created through the modification of other objects.

All objects can either be modified interactively or by means of the available
menu or keyboard commands. How this is done is described in the following
sections.
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Creating objects
To create an object, select the appropriate Object Tool from the Toolbar. We see a difference
between closed objects (rectangle, oval or polygon) and line objects as well as between original
and Alias objects. To learn how to create and work with Alias objects, please refer to the section
Working with Alias Objects.

Objects can be created on the document page or on the pasteboard beside the page. Objects
can also be created over several pages in Facing Page Mode.

While creating an object the application gives you feedback about the size and form of the
object through a dotted imaginary line, which shows you the object‘s appearance when you
release the mouse button. The Ruler and the Module Palette also give information about the
size and position of the object created.

TIP:
- Objects that touch the edge of the page should run over between 3 and 5 mm into the clip-

board area (bleed).
- When creating objects, check the information in the Ruler and in the Module Palette.
- Refer to the sections Objects with predefined settings and Create Alias Objects.

Creating closed objects

To create a rectangle/square, an oval/circle or a polygon, select the appropriate tool from the
Toolbar.

Create a rectangle or square interactively:

1. Choose a tool for a rectangular object from the Toolbar:

- Choose Rectangular Graphic Object to create a rectangular graphic object.

- Choose Rectangular Text Object (Type 1) to create a rectangular text object with text run-
ning from left to right.

- Choose Rectangular Text Object (Type 2) to create a rectangular text object with text
running from right to left (e.g. for Arabic, Hebrew, etc.).

- Choose Rectangular Text Object (Type 3) to create a rectangular text object with text
running from top to bottom (e.g. for Chinese, etc.).

- Choose Rectangular Picture Object to create a rectangular picture object.

2. Click in the document window on the position where the object should be created and hold
down the mouse button.

3. Keep the mouse button held down and move the mouse in any direction.

- Hold down the Shift key as well if you want to create a square.

4. Release the mouse button when the object has the desired size.

As well as the interactive creation of a rectangle or square with the mouse, a rectangle or
square may be created automatically. No object should already be selected since it would be
modified.
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Create a rectangle/square automatically:

1. Choose one of the following options to create a graphic object:

- Press the shortcut keys Ctrl + Shift + G (Windows/Linux) or Command-Shift + G (Mac).

- Select the menu command Object > Content > Graphic.

2. Choose one of the following options to create a text object:

- Press the shortcut keys Ctrl + Shift + T (Windows/Linux) or Command-Shift + T (Mac).

- Select the menu command Object > Content > Text.

3. Select one of the following options to create a picture object:

- Press the shortcut keys Ctrl + Shift + B (Windows/Linux) or Command-Shift + B (Mac).

- Select the menu command Object > Content > Picture.

The object will now be created at the upper left sector of the document page and selected. With
an additional option you can modify the radius of the angle.

Create a curved rectangle:

1. Create a rectangle.

2. Select one of the following options:

- Enter a value in the Radius field of the Frame section of the Object Settings dialog or
choose a value from the popup menu.

- Enter a value in the Radius field of the Module palette or choose a value from the popup
menu

Reference:
With the rectangle tool you can also create derivative forms such as parallelograms. Please
refer to the section Skew objects.

Create an oval/circle interactively:

1. Choose a tool for an oval object from the Toolbar:

- Choose Oval Graphic Object to create a oval graphic object.

- Choose Oval Text Object (Type 1) to create a oval text object with text running from left
to right.

- Choose Oval Text Object (Type 2) to create a oval text object with text running from right
to left (e.g. for Arabic, Hebrew, etc.).

- Choose Oval Text Object (Type 3) to create a oval text object with text running from top
to bottom (e.g. for Chinese, etc.).

- Choose Oval Picture Object to create a oval picture object.

2. Click in the document window on the position where the object should be created and hold
down the mouse button.

3. Keep the mouse button held down and move the mouse in any direction.

- Hold down the Shift key as well if you want to create a circle.4
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4. Release the mouse button when the object has the desired size.

Reference:
With the oval tool you can also create derivative forms such as half circles. Please refer to
the section Delete handles.

Create a polygon:

1. Choose a tool for an polygon object from the Toolbar:

- Choose Polygonal Graphic Object to create a polygonal graphic object.

- Choose Polygonal Text Object (Type 1) to create a polygonal text object with text running
from left to right.

- Choose Polygonal Text Object (Type 2) to create a polygonal text object with text run-
ning from right to left (e.g. for Arabic, Hebrew, etc.).

- Choose Polygonal Text Object (Type 3) to create a polygonal text object with text run-
ning from top to bottom (e.g. for Chinese, etc.).

- Choose Polygonal Picture Object to create a polygonal picture object.

2. Click in the document window on the position where the object should be created and hold
down the mouse button.

3. Keep the mouse button held down and move the mouse in any direction.

- Hold down the Shift key as well if you want to draw a line segment at an angle of 0 (zero)
or 90 degrees.

4. Click the mouse button once to complete a line segment and move the graphic object
pointer in any direction to create the next line segment.

5. Repeat this for every line segment.

6. Double-click to complete and close the drawing process. The line segments will be con-
nected automatically.

Reference:
With the Polygon tool you can also create Bézier objects.

Create line objects

The program makes three tools available to you which allow you to draw lines. The application
differs between the tools for drawing a

- straight line with any angle,

- an orthogonal straight line and

- a multiple line consisting of several line segments.

Create a simple straight line:

1. Select the Line tool from the Toolbar.

2. Click on the document page in the document window and hold down the mouse button.

3. Move the mouse in any direction while holding down the mouse button.5
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- Hold down the Shift key to draw an orthogonal straight line with an angle of 0 (zero), 45
or 90 degrees.

4. Release the mouse button when your line is of the required length.

Create an orthogonal line:

1. Choose the Orthogonal Line tool from the Toolbar.

2. Click on the document page in the document window and hold down the mouse button.

3. Move the mouse in any direction while holding down the mouse button. The orthogonal line
follows the horizontal or vertical position of the mouse pointer. The orthogonal line will
however change its direction by 45 degrees when the angle between the line and the mouse
pointer is greater than 22,5 degrees.

- Hold down the Shift key to draw a straight line with any angle.

4. Release the mouse button when your line is of the required length.

TIP:
To make an angled line from an orthogonal line and vice versa, hold down the Shift key when
editing or drawing.

Create a multiple line:

1. Choose the Multiple Line tool from the Toolbar.

2. Click the mouse pointer in the document window on the position where the object should be
displayed and hold down the mouse button.

3. Move the mouse in any direction while holding down the mouse button.

- Hold down the Shift key when a line segment with an angle of 0 (zero) or 90 degrees
should be drawn.

4. Click the mouse button once to complete a line segment and move the mouse pointer in any
direction to create the next line segment.

5. Repeat this for every additional line segment.

6. Double-click to complete and close the drawing process.
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Summary Creating Objects
- Rectangles are created with a Rectangle tool in the Toolbar. By holding down the Shift key

a square will be created.

- To create a rectangle automatically, select the appropriate object type in the Object menu
or use the corresponding shortcut keys:

- Graphic object: Ctrl + Shift + G (Windows/Linux) or Command + Shift + G (Mac)

- Text object: Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac)

- Picture object: Ctrl + Shift + B (Windows/Linux) or Command + Shift + B (Mac)

- Make sure no object is already selected before using the command.

- Rectangles with rounded corners can be created with the help of the Radius option in the
Module palette or the Object Settings dialog.

- Ellipses/Ovals are created with an Oval tool in the Toolbar. Holding down the Shift key
while drawing automatically creates circles.

- Simple straight lines are created through the Line tool in the Tool-bar. Holding down the
Shift key while drawing automatically creates vertical or horizontal orthogonal lines.

- Orthogonal lines are drawn through the Orthogonal Line tool in the Toolbar. Holding down
the Shift key while drawing automatically creates diagonal lines.

- Multiple lines are drawn through the Multiple Line tool in the Tool-bar. Holding down the
Shift key while drawing automatically creates only horizontal or vertical line segments. A
double-click completes the creation of a multiple line.

- Polygons are drawn through the Polygon tool in the Toolbar. Holding down the Shift key
while drawing automatically creates only horizontal or vertical line segments. A double-
click completes the creation of a polygon and the first and last line segments will be con-
nected.

- Open curves are created by converting multiple lines. Position the mouse pointer on the
sizing handle of a multiple line and hold the Ctrl key Windows/Linux/Mac) and the mouse
button down, stretch the handle by moving the mouse. The corresponding mouse pointer
will be displayed.

- Closed curves are created by converting a polygon. Position the mouse pointer on a sizing
handle of the polygon and hold the Ctrl key (Windows/Linux/Mac) and the mouse button
down, stretch the handle by moving the mouse. The corresponding mouse pointer will be
displayed.

- A newly created object will have the same graphic properties as a previously created
object if the previously created object is selected before the appropriate object tool is acti-
vated in the Toolbar.

- One or more Alias objects can be created from any original object.

- One or more Alias objects can also be created from any Alias object.
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Selecting objects
As soon as the mouse pointer is positioned on top of a graphic object or its frame the Object
pointer is displayed. This mouse pointer shows you that the object can be selected by means of
a mouse-click. The same is true if you move the mouse pointer to the frame of a text or picture
object, and here there is an additional feature: As soon as you move the mouse over the surface
of a text or picture object, the mouse pointer will change into an I-beam (text) or grabber hand
(picture), while a gray selection button appears in the middle of the object. If you move the
mouse over the button, the mouse pointer will change into the Object pointer.

After the mouse-click the selection handles are shown. The term selection handles describes the
sizing handles and control handles of an object. Lines and polygons have selection handles at
every corner point. Ellipses/ovals and rectangles always have eight selection points. As well as
the display of the selection handles, the attributes applied to the object appear in the Object
Palette (Module Palette in Object mode). If the Object Palette is visible, its co-ordinates are dis-
played.

Select objects with a mouse-click:

1. Choose one of the following options:

- Position the mouse pointer on a closed graphic object or a line.

- Position the mouse pointer on the object frame of a picture or text object.

- Position the mouse pointer on the picture or text object and hold down the Ctrl key
(Windows/Linux) or the Command key (Mac).

- Position the mouse pointer on the gray selection button in the middle of the picture or
text object.

2. Click the mouse button as soon as the Object pointer is shown.

3. To select several objects, repeat points 1 and 2 while holding down the Shift key.

4. To select a hidden object that is completely covered by other objects, hold down the keys
Ctrl + Alt + Windows + Shift (Windows/Linux) or Ctrl + Alt + Command + Shift (Mac) and click
the mouse button repeatedly until the required object is selected. This procedure may be
repeated as often as you like. All objects whose surface is under the mouse pointer position
will be found.

Objects can also be selected by dragging an imaginary rectangle over them.

Select objects through dragging:

1. Position the mouse pointer somewhere on the page where there is no object.

2. Hold down the mouse button and drag the selection rectangle in the direction of the objects
you want to select.

3. Release the mouse button when the selection rectangle covers all the objects you wanted to
select.
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Select all objects:

Choose one of the following options:

- Select the menu command Edit > Select All from the menu.

- Press the shortcut keys Ctrl + A (Windows/Linux) or Command + A (Mac).

In single page mode all objects on the page and on the pasteboard area will be selected. In
facing page mode, all the objects on the left and right hand page and also on the pasteboard
area will be selected.

REFERENCE:
The program offers the possibility of steering the selection of certain objects (e.g. Guide
objects, Alias objects, etc.). If one or more objects cannot be selected, please refer to the sec-
tions Working with Guide Objects and Working with Alias Objects.

The program offers several possibilities for deselecting an object:

Deselect all selected objects:

Choose one of the following options:

- Position the mouse pointer somewhere on the page where there is no object and click the
mouse button.

- Hold down the Shift key and click the frame of the object to be deselected or use the
dragging method.

- Hold down the Shift key and click the gray selection button in the middle of a picture or
text object.

- Select another object.
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Summary Selecting objects
- Objects are selected through the Object pointer.

- In Single Page Mode, only objects on the current page and the Pasteboard area are select-
able.

- In Facing Page Mode all objects on both left and right hand pages as well as on the Paste-
board area are selectable.

- All objects on the current page can be selected with the command Edit > Select All or with
the shortcut keys Ctrl + A (Windows/Linux) or Command + A (Mac).

- When the mouse pointer is over a text or picture object the Ctrl key (Windows/Linux) or
Command key (Mac) must be pressed to select the object if you do not want to position the
mouse pointer exactly on the frames of these objects.

- Selection handles of original objects are filled blue square points (sizing handles) and
round points (control handles).

- Selection handles of Alias objects are filled light blue points and their control handles are
filled light blue round points.

- Multiple objects can be selected by dragging the selection rectangle in the direction of the
objects you want to select.or by holding down the the key and clicking each object with
the mouse. If the objects are text or picture objects, then the Ctrl key (Windows/Linux) or
Command key (Mac) must also be held down.

- To select hidden objects, the Ctrl + Alt + Windows-Shift (Windows/Linux) or Ctrl + Option +
Command + Shift (Mac) shortcut keys and the mouse button must be pressed until the
selection handles of the object are shown.
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Positioning objects
The program provides many options for the positioning of objects. You can move, align or dis-
tribute objects.

Move objects

In selecting objects you have already met the graphic mouse pointer whose arrowheads point
in all four directions. This pointer is also used for moving objects.

Move object with the mouse:

1. Select one or more objects.

2. Hold down the mouse button AND the Ctrl key (Windows/Linux) or the Command key (Mac)
and move the mouse in the preferred direction.

- While moving the objects with the mouse, hold down the Shift key to move the objects
only horizontally or vertically.

When the Object palette is active the current position of the object is shown exactly as soon as
you release the mouse button.

Move/nudge object with the keyboard:

1. Select one or more objects.

2. Use the arrow nudge keys on the keyboard to move or nudge objects one screen pixel at a
time in the appropriate zoom factor:

- Press the Nudge-Right key or the Nudge-Left key to move/nudge objects horizontally.

- Press the Nudge-Up key or the Nudge-Down key to move/nudge objects vertically.

During object dragging the outer dimension of the object is shown. You can now move the
object around on the current page or to other pages. When the ruler is active the position of the
active object is indicated by means of unconnected lines in the ruler display area, so that a rel-
atively exact positioning is possible.

When the Object palette is active the current position of the object is shown exactly.

Apart from the interactive positioning of objects it is also possible to do this in a precise manner
through various commands. We will differentiate between absolute and relative positioning.

- Absolute positioning means the selected objects are moved to a specific position. The
application offers you two ways to do this : through the Object Settings dialog or through
the Object palette.

- Relative moving means the selected objects will be moved with a specified factor.

Move objects with the Module palette:

1. Select one or more objects.

2. Enter the required co-ordinates in the entry field X or Y of the Module palette:

- Replace the values in the entry fields to position the objects absolutely.
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- Enter a factor (e.g. +10) to move the objects relatively. Positive values move the objects to
the right or downwards. Negative values move the objects to the left or upwards.

3. As an extra option you can select the reference point for the X and Y co-ordinates. The
default reference point is Top Left. The default reference point for lines and orthogonal lines
is Start.

Move objects with the Object Settings dialog:

1. Select one or more objects.

2. Choose one of the following options:

- Double-click one of the selected objects (graphic objects).

- Double-click the frame of one of the selected text or picture objects.

- Double-click the gray selection button in the middle of one of the selected text or picture
objects.

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Choose the command General in the Context menu with the mouse over the frame or the
gray selection button in the middle of one of the selected text or picture objects, or over
the frame or surface of a selected graphic object .

3. Enter the required co-ordinates in the fields Horizontal Offset and/or Vertical Offset for
closed objects:

- Replace the values in the entry fields to position the objects absolutely.

- Enter a factor (e.g. +10) to move the objects relatively, providing they all have the same
co-ordinates. Positive values move the objects to the right or downwards. Negative val-
ues move the objects to the left or upwards.

4. Click OK to close the dialog

Changing object hierarchy

Objects are assigned to a certain layer in the order in which they are created. This can be shown
by the fact that a newly created object will be drawn on top of the other object. In practice it
will seldom happen as you will create objects in exactly the same sequence you will use them
later.

The commands Send to Front, Send Forward, Send Backward and Send to Back in the Object
menu and in the Context menu for Objects as well as their shortcuts allow you to lay objects
over or under one another in any sequence.

Change object hierarchy:

1. Select one or more objects.

2. Choose one of the following options to bring the selected objects in the hierarchy to the
front:
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- Press the shortcut keys Ctrl + Plus (Windows/Linux) or Command + Plus (Mac).

- Choose the menu command Object > Send to Front.

- Choose the command Send to Front in the Context menu.

3. Choose one of the following options to send the selected objects in the hierarchy to the back:

- Press the shortcut keys Ctrl + Minus (Windows/Linux) or Command + Minus (Mac).

- Choose the menu command Object > Send to Back.

- Choose the command Send to Back in the Context menu.

4. Choose one of the following options to send the selected objects in the hierarchy one level
forward:

- Press the shortcut keys Ctrl + Alt + Plus (Windows/Linux) or Command + Alt + Plus (Mac).

- Choose the menu command Object > Send Forward.

- Choose the command Send Forward in the Context menu.

5. Choose one of the following options to send the selected objects in the hierarchy one level
backwards:

- Press the shortcut keys Ctrl + Alt + Minus (Windows/Linux) or Command + Alt + Minus (Mac).

- Choose the menu command Object > Send Backward.

- Choose the command Send Backward in the Context menu.

Object alignment

Another option to change the position of objects is through the Alignment command. This is
especially useful if several objects have to be positioned in a certain way relative to another.

Align objects with menu commands:

1. Select at least two objects.

2. Choose one of the following options:

- Select the menu command Object > Alignment.

- Select the command Alignment in the Context menu.

3. Choose a corresponding option from the popup menu:

- Choose the command Left Edge to align all selected objects on the left edge of the
selected object whose left edge is furthest to the left.

- Choose the command Center horizontally to center all selected objects on the horizontal
center axis of the object selection.

- Choose the command Right Edge to align all selected objects on the right edge of the
selected object whose right edge is furthest to the right.

- Choose the command Center to align all selected objects on both the horizontal and ver-
tical center axes of the object selection.
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- Choose the command Top Edge to align all selected objects on the top edge of the
selected object whose top edge is the furthest up the page.

- Choose the command Center vertically to center all selected objects on the vertical center
axis of the object selection.

- Choose the command Bottom Edge to align all selected objects on the bottom edge of the
selected object whose bottom edge is the furthest down the page.

You can also align Objects with the menu command Align/Distribute. The dialog displays a
preview of how the selected objects will be aligned.

Align objects with the Align/Distribute dialog:

1. Select at least two objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + Comma (Windows/Linux) or Command + Comma (Mac).

- Select the menu command Object > Alignment > Align/Distribute.

- Select the command Alignment > Align/Distribute in the Context menu.

3. Choose one or more of the following options:

- Choose the option Horizontal and Spacing as well as the option Left Edge in the popup
menu Between to align all selected objects on the left edge of the selected object whose
left edge is furthest to the left.

- Choose the option Horizontal and Spacing as well as the option Center in the popup
menu Between to center all selected objects on the horizontal center axis of the object
selection.

- Choose the option Horizontal and Spacing as well as the option Right Edge in the popup
menu Between to align all selected objects on the right edge of the selected object whose
right edge is furthest to the right.

- Choose the option Vertical and Spacing as well as the option Top Edge in the popup
menu Between to align all selected objects on the top edge of the selected object whose
top edge is the furthest up the page.

- Choose the option Vertical and Spacing as well as the option Center in the popup menu
Between to center all selected objects on the horizontal center axis of the object selec-
tion.

- Choose the option Vertical and Spacing as well as the option Bottom Edge in the popup
menu Between to align all selected objects on the bottom edge of the selected object
whose bottom edge is the furthest up the page.

4. Click OK to close the dialog.

Several objects selected together may also be aligned using the Object palette or the Object
Settings.
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Align objects with the Module palette:

1. Select at least two objects.

2. Enter appropriate values in the Module Palette:

- Enter a value in the entry field X to align the selected objects horizontally. If a left reference
point is selected in the Module Palette, the objects will be aligned left on this point. If a
right reference point is selected, objects will be aligned right on this point. If a center
point is selected in the Module Palette, the objects will be centered horizontally on this
point.

- Enter a value in the entry field Y to align the selected objects vertically. If a top reference
point is selected in the Module Palette, the objects will be top aligned on this point. If a
bottom reference point is selected, objects will be bottom aligned on this point. If a center
point is selected in the Module Palette, the objects will be centered vertically on this point.

Align objects with the Object Settings dialog:

1. Select at least two objects.

2. Choose one of the following options:

Double-click the selected objects and at the same time hold down the Ctrl key (Windows/Linux)
or the Command key (Mac), when among the selected objects is a text object or a picture
object.

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General

- Choose the command General in the Context menu. Hold down the Ctrl key (Windows/
Linux) or the Command key (Mac), when among the selected objects is a text object or a
picture object.

3. Select one or more of the following options:

- Enter a value in the entry field Horizontal Offset to align the selected objects horizontally.

- Enter a value in the entry field Vertical Offset to align the selected objects vertically.

4. Click OK to close the dialog.

Rotate and Mirror

The commands Rotate and Mirror allow modification of objects and their position.

Rotate and Mirror are two related commands. While a rotation is only specified through its
rotation angle, the mirroring function will additionally also set the Mirror property. For this
reason the two functions will be explained here together. As in the case of the positioning of
objects the application differentiates between interactive versus precise and absolute versus
relative rotation and mirroring.

Through the Rotate tool and the Mirror tool in the Toolbar objects can be rotated and mirrored
interactively.
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To rotate or mirror an object in a precise way the application allows you to enter precise values
in the Object Settings dialog box or the Object palette.

Rotate or mirror an object Interactively:

1. Select an object.

2. Choose a tool from the Toolbar:

- Select the Rotate tool. The Rotate pointer will appear.

- Select the Mirror tool. The Mirror pointer will appear.

3. Do one of the following:

- Click the Rotate pointer near the object, hold down the mouse button, and move the
mouse along the preferred rotation angle. The point at which you click is the rotation
point, so it is advisable to click as near as possible to one of the object selection points.
The application will show you the original and current angle of rotation interactively. By
lengthening the rotation axis you will get a more precise preview. Release the mouse
button to confirm the setting. The Rotation Angle will be displaced in the Module palette
with an accuracy of three decimal places.

- Click the Mirror pointer near the horizontal object axis (top, middle or bottom) on which
the mirroring should take place. The object is mirrored horizontally, which means that
the top is now the bottom. For a “vertical” mirroring, you now need to rotate the object
by 180 degrees.

Please note that if you apply the Mirror tool again, the mirroring of the object will be
undone. If you wish to change the rotation angle interactively with the help of the mouse but
still wish to retain the mirroring, the Rotate tool must be used.

Rotate/Mirror object precisely with Object Settings:

1. Select an object.

2. Select one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Select the menu command Object > General.

- Select the command Object > General in the Context menu.

3. In the Rotation Angle entry field enter a value between + 360 or - 360 degrees to rotate the
object.

4. Select the Mirrored option if the object is to be mirrored along its horizontal axis.

- If you want the object to be mirrored and rotated at the same time select the Mirrored
option and enter a Rotation Angle.

5. Click OK to close the dialog.

Rotate and mirror objects precisely with the palette:

1. Select an object.

2. Set the Reference Point of the object to Center.16
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3. Click the Rotate entry field in the Object palette and enter a value in the range between -
360 and + 360 degrees.

4. Click the checkbox Mirrored to mirror the object horizontally.

5. Confirm by pressing the Tab, Return or Enter key.

Through the commands described an absolute rotation angle has been set for an object.

Skew objects

Another option to modify the position of an object is through the Skew Angle setting. Either a
positive or negative angle may be entered in this entry field. Modification of the Skew Angle
will transform the object. This can be applied to all closed objects.

If the Skew Angle is specified for text or picture objects the content of these objects will also be
transformed. Please note that there are additional options for skewing text passages and
images, which will be described in the appropriate chapters and which take a cumulative
effect.

Skew Object with Module Palette:

1. Select an object.

2. Enter a value in the Skew Angle data entry field. Values between +1 and +75 give a skew to
the left, values between -1 and -75 give a skew to the right.

- You can click the arrow buttons to increase or decrease the angle by one degree at a
time. Hold down the mouse button to scroll through the settings.

Skew Object with Object Settings dialog:

1. Select an object.

2. Choose one of the following options:

- Double-click the selected object.

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Select the menu command Object > General.

- Select the command General in the Context menu.

3. Enter a value in the Skew Angle data entry field. Values between +1 and +75 give a skew to
the left, values between -1 and -75 give a skew to the right.

4. Click OK to close the dialog.

As well as original objects, Alias objects may also be rotated and skewed.
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Basic commands

Delete objects

Selected objects can deleted by using the Delete command.

Delete objects:

1. Select one or more objects.

2. Choose one of the following options:

- Press the Del key.

- Press the Backspace key.

- Choose the menu command Edit > Delete.

Tip:
If an original object is deleted that possesses Alias Objects that are not selected, a warning
will appear that allows the user to cancel his command. Please refer to the section Working
with Alias Objects.
Reference:
Section Pasting objects
Section Undo
Section Working with Alias Objects

Cut objects

Cutting objects is similar in its function to deleting objects. Objects which are cut disappear,
but they are copied to the clipboard and reappear again with the command Paste.

Cut objects:

1. Select one or several objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + X (Windows/Linux) or Command + X (Mac).

- Choose the menu command Edit > Cut.

- Choose the command Cut in the Context menu.

Tip:
When an object which has connected Alias objects is cut, a dialog will prompt you to confirm
or cancel the operation. Please refer to the section Working with Alias Objects.
Reference:
Pasting Objects
Working with Alias Objects

Copy objects

When you need the same object more than once you can create a copy of one or more existing
objects. The selected objects are copied to the clipboard, and can be pasted back in the document
with the command Paste.18
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Copy objects:

1. Select one or more objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + C (Windows/Linux) or Command + C (Mac).

- Choose the menu command Edit > Copy.

- Choose the command Copy in the Context menu.

Tip:
When the original object should be copied that has unselected Alias objects a warning dialog
will appear prompting the user to reverse his decision. Please see the section Working with
Alias objects for further details.
Reference:
Section Pasting Objects
Section Duplicating Objects
Section Working with Alias Objects

Pasting Objects

When you have cut or copied objects to the clipboard these can be pasted through the Paste
command.

Paste objects:

1. Select the document page on which the cut or copied objects are to be pasted.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + V (Windows/Linux) or Command + V (Mac).

- Choose the menu command Edit > Paste.

- Choose the command Paste in the Context menu.

Tip:
- The paste offset can be specified in the Preferences dialog (Pages & Objects Tab) through

the menu command Edit > Preferences.
- When the objects have connected Alias objects these will automatically also be pasted. If

there are insufficient pages available in the document to paste the Alias objects to they
will only be pasted to the pages which are available in the document.

Reference:
Section Working with Alias Objects
Section Preferences

Duplicate objects

The Duplicate command is similar to the Copy command. The main difference is that the Copy
command makes only one copy of the object, which can be pasted into the document with a
predefined offset. The Duplicate command allows you to make multiple copies of objects.
Objects can also be copied automatically to following pages with this command.
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Duplicate objects:

1. Select one or several objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + D (Windows/Linux) or Command + D (Mac).

- Select the menu command Object > Duplicate.

3. Enter a value in the field Duplications in the Number section.

4. Enter in the fields Horizontal Offset and Vertical Offset the offset that should be applied to
each duplicate. If you enter the value 0 in both cases, all duplicates will be placed on top of
each other.

5. Define the object type:

- Choose the option Copy, if independent duplicates are to be created.

- Choose the option Alias, if dependent duplicates are to be created.

6. Define the page:

- Choose the option Current Page, if the duplicates should be placed on the current page.

- Choose Duplicate on Following Page(s), if the duplicates are to be placed on following
pages, whereby you can choose one of the options Left Pages, Right Pages or Left and
Right Pages. In this case one duplicate will be placed on each following page.

7. Select the option Link to Text Chain when the original object is a text object and you want
the text to flow into the duplicate objects.

8. Click OK to close the dialog.

Split objects

Another elegant option to create new objects is through the Split command. All object types
can be split, whether they are Graphic, Picture or Text objects. However the following objects
can not be split : objects which are part of a text chain, locked or protected objects, Alias
objects and original objects with connected Alias objects.

Split objects:

1. Select one or more objects.

2. Select one of the following options:

- Press the shortcut keys Ctrl + Alt + Shift + T (Windows/Linux) or Command + Option + Shift
+ T (Mac).

- Select the menu command Object > Split.

3. Enter the number of sections in the fields Horizontal and/or Vertical. As an option, you can also
enter a horzontal and/or a vertical offset in the fields on the right hand side of the dialog.

4. Define the object type in the Create section:

- Select the option Copy, if independent duplicates are to be created.
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- Select the option Alias, if dependent duplicates are to be created. In this case the original
object will be located in the top left corner. All other objects are Alias objects derived
from it.

5. Select the option Link to Text Chain when the original object is a text object and the new
objects are to be part of the text chain.

6. Click OK to close the dialog.

Lock objects

With the command Lock you prevent the interactive repositioning and resizing of objects (by
mistake).

If the mouse pointer is moved over the frame of a locked object the lock pointer will be dis-
played. The lock pointer for objects, consisting of a lock and an object pointer, shows that the
object concerned is locked and therefore cannot be moved.

Lock objects:

1. Select one or more objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + Shift + L (Windows/Linux) or Command + Shift + L (Mac).

- Choose the menu command Object > Lock.

Unlock objects:

1. Select one or more locked objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + Alt + Shift + L (Windows/Linux) or Command- Option + Shift + L
(Mac).

- Select the menu command Object > Unlock.

TIP:
As well as original objects, it is also possible to lock Alias objects. Please note, however, that
the locking of Alias objects is under certain circumstances only of a temporary nature. This is
the case when the original object is resized - the Alias object will change accordingly. In this
case the locked Alias objects must be unlocked automatically, because the connection
between original and Alias Objects is absolute.
Reference:
Section Paste objects
Section Duplicate Objects
Section Working with Alias Objects
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Protect objects

With the command Protection you prevent the content of certain objects from being altered.

If the mouse pointer is moved over a protected object, the lock pointer will be displayed. The
lock pointer for text objects consists of a lock and an I-beam pointer. The lock pointer for picture
objects consists of a lock and a grabber pointer. Both show that the content of the object is
protected and can therefore not be edited.

Protect objects:

1. Select one or more objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + Shift + H (Windows/Linux) or Command -Shift + H (Mac).

- Choose the menu command Object > Protection.

Cancel protection:

1. Select one or more protected objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + Shift + H (Windows/Linux) or Command-Shift + H (Mac).

- Choose the menu command Object > Cancel Protection.

Modifying object properties

Resizing objects interactively

The program provides many options to define the size and form of objects interactively or with
the help of palettes and dialogs.

When an object is selected, its selection handles will appear as described in the section Selecting
Objects. The selection handles show that the object may be modified. The selection handles are
displayed in the selection color and are not printed.

Selection handles are either sizing handles or control handles. Rectangles, ovals, polygons,
lines and orthogonal lines all have sizing handles that are displayed as a rectangle. Bézier
curves and closed Bézier objects also have control handles, which are displayed as points. A
sizing handle may have one or two tangents at whose end points control handles are displayed.

To resize an object, position the mouse pointer exactly on one of the sizing handles. The mouse
pointer will be positioned exactly on a sizing handle when the sizing pointer is displayed. If
you now hold down the mouse button and drag the mouse in the required direction, the object
will be resized.

During the resizing operation, you will see the same imaginary frame or the same imaginary
line that you already know from the creation of a new object.
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Resize/scale rectangle and oval interactively:

1. Create a rectangle or an oval.

2. Change the size and form of thje rectangle or oval using the eight sizing handles:

- Position the mouse pointer on one of the four middle sizing handles if you only want to
resize the object’s height or width.

- Position the mouse pointer on one of the four sizing handles at the object corners if you
want to resize the object‘s height and width simultaneously.

3. Hold down the mouse button.

4. Keeping the mouse button held down, move the mouse in any direction.

- Hold down the Shift key as well if you want to resize the object proportionally.

- Hold down the Ctrl key as well as the Shift key if you have selected a corner sizing handle
and also want to resize the image content proportionally with the picture object.

- Hold down just the Ctrl key if you have selected a corner sizing handle and also want to
resize the image content unproportionally with the picture object.

5. Release the mouse button when the object has the desired form and size.

Resize polygons and lines interactively:

1. Create a polygon, a line, an orthogonal line or a multiple line.

2. Position the mouse pointer on a sizing handle and hold down the mouse button.

3. Keeping the mouse button held down, move the mouse in any direction.

- When resizing a polygon or a multiple line, hold down the Shift key if a line segment
should be displayed as an orthogonal line.

- When resizing a line, hold down the Shift key if the line should be displayed as an
orthogonal line.

- When resizing an orthogonal line, hold down the Shift key if the orthogonal line should
be displayed as a line with any angle.

4. Release the mouse button when the object has the desired form and size.

Resize curves and Bézier objects:

1. Create a curve, an orthogonal line or a multiple line.

2. Position the mouse pointer on a sizing handle if the curve is to be resized symmetrically and
hold down the mouse button.

3. Position the mouse pointer on a control handle if the curve is to be resized asymmetrically
and hold down the mouse button:

- Keeping the mouse button held down, move the mouse in any direction to lengthen the
tangent.

- When resizing the curve, hold down the Ctrl key as well if you want to keep both tangents
the same size.23
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- Keeping the mouse button held down, move the mouse in any direction and hold down
the Shift and Ctrl keys as well to break the tangent.

4. Release the mouse button when the object has the desired form and size.

Delete sizing handles

With multiple lines, polygons, open and closed curves the application allows you to delete one
of the object‘s selection handles. Move the mouse pointer over the sizing handle or control
handle which is to be deleted.

The sizing pointer will now appear. If you now press the Alt + Shift (Windows/Linux) or the
Option + Shift shortcut keys (Mac), the sizing pointer will be displayed with a minus sign. Now
you can delete the point by clicking the mouse button. When a sizing handle is deleted, its
control handles will automatically be deleted with it.

Delete sizing and control handles:

1. Position the mouse on a sizing handle or control handle, hold down the Alt + Shift (Win-
dows/Linux) or Option + Shift shortcut keys (Mac).

2. When the sizing pointer with the minus sign appears, click the mouse button.

Create a half-circle:

1. Create a circular object.

2. Select the menu command Object > Form > Convert to Polygon.

3. Delete the central sizing handle from the bottom edge of the object by holding down the Alt +
Shift (Windows/Linux) or Option + Shift shortcut keys (Mac) and clicking the mouse button.

4. Delete the bottom two control handles from the left and right sides of the object holding
down the Alt + Shift (Windows/Linux) or Option + Shift shortcut keys (Mac) and clicking the
mouse button, so that the bottom sizing points of the object left and right only possess one
tangent.

Add sizing handles

As well as the deleting of both sizing handles and control handles, the application also allows
you to add sizing handles. The new sizing handle will appear on top of the original sizing han-
dle you were modifying and will still have to be positioned.

Add a sizing handle:

1. Select a polygon object.

2. Position the mouse pointer on one of the sizing handles. The sizing pointer will now appear.

3. Hold down the Alt key (Windows/Linux) or the Option key (Mac). The sizing pointer will be
displayed with a plus sign. Now click with the mouse to create the new handle.

4. Release the Alt key (Windows/Linux) or the Option key (Mac), but hold down the mouse but-
ton again and move the sizing pointer in any direction to position the new sizing handle.

5. Release the mouse button once you have achieved the desired shape.24
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Automatic Scaling

As you have already learned in the section Sizing objects interactively, the image content of
rectangles and ovals may also be scaled interactively with the object.

In practice it often occurs that not just one object but a whole group of objects should be dis-
played in a smaller or larger form. For example, when you need to scale down a page from A4
paper size to A5 paper size you would normally have to change all the objects interactively or
numerically with the help of the object measurement settings. This would only change the
frame size but not the content of the frame, which you would have to scale down separately.

To solve this problem quickly and elegantly the application offers you the Scaling command in
the Object menu.

Scale objects and groups proportionally with the dialog:

1. Select a single object or a group of objects. Please refer to the section Working with groups
to see how to create a group.

2. Choose the menu command Object > Scaling.

3. In the section New Size, define the scaling or the new size of the object or group:

- Enter a value between 1% and 1000% in the Scaling field to make a relative scaling. While
with the entry 100% nothing will change in the object measurements, the entry 120% will
mean that the object is enlarged by a factor of 1.20. The value 50% will reduce the object
to half its original size. After the scale factor is entered, the new width and height set-
tings will be computed automatically.

- Alternatively, enter values in the Width and Height entry fields to give an absolute scal-
ing. Since the Scaling command only scales objects and object groups proportionally,
the values in the field Width change whenever the values in the Height field are changed.
This is also true the other way around.

4. Define in the section Scaling Attributes whether and which object and content attributes
should be scaled:

- Select the option Line Width if the line or frame width should be scaled proportionally.

- Choose the option Picture Attributes, if the scaling of the image content and its position-
ing in the object should be scaled proportionally.

- Choose the option Text Attributes, if text attributes such as font size, text indents or line
spacing should be scaled proportionally.

- Choose the option Text Object Indent if the special indent settings of the text object
should be scaled proportionally.

- Choose the option Column Gutter if the gutter in a text object with several columns
should be scaled proportionally.

5. Click OK to close the dialog.
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Summary Resizing objects
- Sizing handles control object size.

- Control handles control the curvature of a line.

- Sizing handles and control handles can be moved in any direction.

- The two control handles of a sizing handle can be at different distances from it.

- The slope control of one tangent line can be split into two tangent lines by holding down
the Ctrl + Shift (Windows/Linux) or the Command + Shift shortcut keys (Mac).

- Sizing handles and control handles can be deleted by holding down the Alt + Shift (Win-
dows/Linux) or Option + Shift shortcut keys (Mac), and clicking the points to be deleted.

- The deletion of a sizing handle will automatically delete its control handles.

- Sizing handles can be added by pressing the Alt key (Windows/Linux) or Option key (Mac)
and clicking the mouse with the sizing pointer over an existing sizing handle.

- Multiple objects can be resized proportionally using the command Scale.

- Object scaling can be relative or absolute.

- As well as the object size, its content can be scaled.

Object fill

Fill Color, Density, Transparency

The following properties may be changed either through the Module palette or with the set-
tings in the Object Settings dialog. With new documents the program provides a set of stan-
dard colors. To learn how to create new colors and blends, to edit and delete them, please refer
to the section Working with Colors.

Change fill color with the Module palette:

1. Create or select a closed object.

2. Select a color or blend from the popup menu Color in the Fill section in the Module Palette.

3. Define the color shade in the Shade field:

- Enter a value between 0% and 100%, or select an entry from the popup menu to define
the fill color shade.

- Enter the value -1 or Transparent, or select the entry Transparent from the popup menu
to switch off the fill color.

4. Define the opacity/transparency of the fill color in the Opacity field:

- Enter a value between 0% and 100%, or select an entry from the popup menu.

5. Enter a value in the field Color Blend Angle if the fill color is a blend.
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Change fill color with the Object Settings:

1. Create or select a closed object.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Select the command General in the Context menu.

- Double-click the selected object.

3. Choose a color or blend from the popup menu Color in the Fill Color section.

4. In the Shade field of the Fill Color section, define the density or transparency of the color:

- Enter a value between 0% and 100%, or select an entry from the popup menu to define
the fill color shade.

- Enter the value -1 or Transparent, or select the entry Transparent from the popup menu
to switch off the fill color.

5. Enter a value in the field Color Blend Angle if the fill color is a blend.

6. Define the opacity/transparency of the Fill Color in the Opacity field:

- Enter a value between 0% and 100%, or select an entry from the popup menu.

7. Click OK to close the dialog.

Lines and Frames

Line Color, Shade, Transparency

With new documents the program provides a set of standard colors. To learn how to create new
colors and blends, to edit and delete them, please refer to the section Working with Colors.

Change Line color with the Module palette:

1. Create or select an object.

2. Choose a color from the popup menu Line Color in the Line/Frame section in the Module Palette.

3. Define the line color shade in the Line Shade field:

- Enter a value between 0% and 100%, or select an entry from the popup menu to define
the color shade.

- Enter the value -1 or Transparent, or select the entry Transparent from the popup menu
to switch off the line or frame color.

4. Define the opacity/transparency of the frame or line in the field Opacity (Line/Frame) in the
Line/Frame section in the Module Palette:

- Enter a value between 0% and 100%, or select an entry from the popup menu.
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Change Line Color with the Object Settings:

1. Create or select an object.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Select the command General in the Context menu.

- Double-click the selected object.

3. Select a color from the popup menu Color in the Frame section.

4. In the Shade field of the Frame section, define the density or transparency of the color:

- Enter a value between 0% and 100%, or select an entry from the popup menu to define
the line/frame color shade.

- Enter the value -1, or select the entry Transparent from the popup menu to switch off the
line/frame color.

5. Define the opacity/transparency of the Frame in the Opacity section:

- Enter a value between 0% and 100%, or select an entry from the popup menu. This entry
is valid for lines and frames.

6. Click OK to close the dialog.

Change Line/Frame Width

The line width of a line object or object frame can be modified through the Object palette or the
Object Settings. When using the line width there are several aspects to be noted:

- Because object coordinates are absolute the line widths of closed objects will always be
drawn on the inside of an object. With line objects the line width will be equally applied to
both sides of the object.

- When a graphic object is converted to a text object the line width is automatically set to 0.

- When a line width is applied to a text object, the text in this object will have the same size
as the line width setting.

- When a line width is applied to criss-cross polygons, this can for mathematical reasons
lead to incorrect results.

Change Line Width with the Module palette:

1. Create or select several objects.

2. Choose one of the following options to define the line or frame width:

- Enter a value in the Line Width field of the Module Palette.

- Choose an entry from the popup menu.
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Change Line width with the Object Settings:

1. Create or select several objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Select the command General in the Context menu.

- Double-click the selected object.

3. Choose one of the following options to define the line or frame width:

- Enter a value in the Width field of the Frame section.

- Select an entry from the popup menu.

4. Click OK to close the dialog.

Change Frame type

A frame type can be defined in the Module palette (in Object Mode) or with the Object Settings.
When using line types there are several aspects to be noted:

- When applying frame types, the program always applies the frame in relation to the line
width, so that the frame always meets at closed object corners and that line objects always
have neat ends.

- The spaces between line segments remain transparent, irrelevant of which color and shade
has been selected for the frame.

Change Line Style with the Module palette:

1. Create or select an object.

2. Choose an entry from the popup menu Line Style in the Module Palette.

Change Line type with the Object Settings:

1. Create or select an object.

2. Select one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Choose the context menu command General.

- Double-click the selected object.

3. Choose an entry from the popup menu Line Style in the Frame section.

4. Click OK to close the dialog.

29



Working with Objects

Change Line ends

The line ends of a line object can be modified through the Module palette (in Object Mode) or
the Object Settings. When using the line ends there are several aspects to be noted:

- When applying line ends you should be aware that the program always applies the end
form in relation to the line width.

- It is also important to note that lines with differing ends may be printed differently,
although they posses the same co-ordinates.

Change Line ends with the Module palette:

1. Create or select a line.

2. Select an entry from the popup menu Line Start and/or Line End in the Module Palette for
one or both ends of the line.

Change Line ends with the Object Settings:

1. Create or select a line.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Choose thecommand General in the Context menu .

- Double-click the selected object.

- Select an entry from the popup menus Line Ends in the Frame section for one or both
ends of the line.

3. Click OK to close the dialog.

Change Radius

The corner radius of a rectangular object can be modified through the Module palette (in
Object Mode) or the Object Settings. When using the radius there are several aspects to be
noted:

- The radius is only applied to rectangles or squares. It has no effect on other objects.

- When a radius is applied to text objects the text at the object corners is automatically
indented according to these settings.

Change radius with the Module palette:

1. Create or select a rectangle or square.

2. Choose one of the following options to define the radius:

- Enter a value in the Radius field of the Module palette.

- Choose an entry from the popup menu Radius.
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Change radius with the Object Settings:

1. Create or select a rectangle or square.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + M (Windows/Linux) or Command + M (Mac).

- Choose the menu command Object > General.

- Choose the command General in the Context menu.

- Double-click the selected object.

3. Choose one of the following options to define the radius:

- Enter a value in the Radius field in the Frame section of the dialog.

- Select an entry from the popup menu Radius.

4. Click OK to close the dialog.

Using Guide Objects
Guide objects are objects which have “magnetic” properties. Guide objects will “attract” other
objects during creation, moving and resizing in a magnet-like way. Guide objects simplify the
positioning of objects in your document since they will automatically align objects for you with
their magnetic characteristics.

Any object regardless of the form and type can be a Guide object which “attracts” other
objects. Therefore all Guide objects may be assigned the same commands as objects that are
not Guide objects. Among these are the exact positioning as well as the changing of the dis-
play.

Guide objects can be created automatically and manually, and shown or hidden with a key-
stroke.

There are seven ways to specify Guide object settings :

- The option Guide Object in the Object Settings dialog in the menu Object > General.

- The option Guide Object in the Object section in the Object palette.

- The option Guide Objects Magnetic in the View menu.

- The Snap to Distance option in the Preferences dialog (Tab Pages & Objects).

- The menu command View > Guide Objects selectable.

- The menu command View > Show/Hide Guide Objects.

- The option Grid: Behind/Front in the Preferences dialog (Tab Program > General, Options
section).

Reference:
Align Objects
Document Setup (Grid)
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Create Guide Objects automatically

The program offers two options to create Guide objects automatically:

1. The automatic creation of Guide objects with the Grid option in the Document Setup dialog.

2. The creation of Guide objects with the Ruler.

- In the first case the program creates horizontal and vertical Guide objects on the first Alias
page.

- In the second case the user creates Guide objects interactively by dragging lines from the
Ruler.

Create Guide object with Ruler:

1. Ensure that the Ruler is shown. If this is not the case,

- press the shortcut keys Ctrl + R (Windows/Linux) or Command + R (Mac).

- choose the menu command View > Show Ruler.

2. Ensure that the Guide objects are visible. If this is not the case,

- press the shortcut keys Ctrl + Alt + G (Windows/Linux) or Command-Option + G (Mac).

- choose the menu command View > Show Guide Objects.

3. Ensure that the Guide objects are selectable so that you can position your Guide objects
later. If this is not the case,

- press the shortcut keys Ctrl + Alt + Shift + G (Windows/Linux) or Command + Option + Shift
+ G (Mac).

- choose the menu command View > Guide Objects Selectable.

4. Position the mouse pointer in the horizontal or vertical ruler to create a horizontal or vertical
line with the Guide object property.

5. Hold down the mouse button and drag a line onto the document page. An imaginary line
will be shown.

6. Release the mouse button at the position of your choice.

The object stays selected and it can be positioned exactly with the Object palette or the Object
Settings.

If you now select the Object Settings dialog, you will see that the Guide object option is acti-
vated. At the same time the program assumes that you need the automatically created Guide
objects to position other objects. therefore the option Print is de-activated, but you can change
this at any time. further, the object is automatically assigned the default color [Guide Objects].
The color [Guide Objects] is predefined in the program as fluorescent green, but may be
changed at any time. For further information on this subject please refer to the chapter Work-
ing with Colors.
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Create Guide Objects manually

Any object regardless of the form and type can be a Guide object which “attracts” other objects
magnetically.

Create Guide object manually:

1. Ensure that the Guide objects are visible. If this is not the case,

- Press the shortcut keys Ctrl + Alt + G (Windows/Linux) or Command + Option + G (Mac).

- Choose the menu command View > Show Guide Objects.

2. Select one or more objects.

3. Choose one of the following options:

- Open the Object Settings and choose the option Guide Object.

- Choose the option Guide Object in the Object section of the Module palette.

4. If the Guide object is not to be output, as with the automatically created Guide objects, .
deactivate the option Print, in the Object Settings or Printable in the Object section of the
Module palette.

Select Guide Objects

Guide objects generally serve as position guides for other objects. This is particularly true of
those Guide objects that are created automatically with the Ruler and are not printed. So that
Guide objects are not selected by mistake, their selectability may be switched on or off for the
whole document.

Guide Objects Selectable On/Off:

Choose one of the following options:

- Press the shortcut keys Ctrl + Alt + Shift + G (Windows/Linux) or Command + Option + Shift
+ G (Mac).

- Select the menu command View > Guide Objects Selectable.

If in front of the command a tick or checkmark is shown, Guide objects are selectable. If no
checkmark is shown they are not selectable. The command is similar to the commands Lock and
Protection in practice, but is much quicker to use.

Show Guide objects

The Grid of Guide objects created through the Document Setup dialog is helpful for exact posi-
tioning. The grid lines themselves are not part of the document layout. In fact in practice most
Guide objects displayed as lines are only useful in positioning.

In order to view the layout of your document you may want to hide all Guide objects which are
not really a part of the basic layout.
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Hide/Show Guide objects:

Choose one of the following options:

- Press the shortcut keys Ctrl + Alt + G (Windows/Linux) or Command + Option + G (Mac).

- Select the menu command View > Show Guide Objects.

Note:
Please note that Guide objects still possess their “magnetic” properties also when they are
hidden. Guide objects which are hidden can not be selected.

You are also able to make use of the fact that you are able to show and hide Guide objects in
the following situation. When you need to focus on something specific while using a large
magnification factor you can temporarily hide objects by first assigning them the guided
object status and then hide them. When you have finished you can zoom out to original size
and disable the guided object and hide status.

Magnetism

If objects are moved or resized in the direction of a Guide Object they will automatically snap
to that Guide Object like a magnet. Whether and at which distance Objects are attracted
depends on the magnetism being activated and the setting for the Snap to distance.

Guide objects are magnetic as default. In the creation of a document it may make sense to dis-
able the magnetism for all Guide objects.

Guide Objects Magnetic On/Off:

Select the menu command View > Guide Objects Magnetic.

If a tick or checkmark appears in front of this command, Guide objects are magnetic. Otherwise
they are not magnetic.

The distance from which an object is attracted magnetically depends on the Snap to distance.
The value for the Snap to distance is entered in screen pixels and as a default is entered as 10
pixels. This value is independent of the scaling factor in which the document is displayed.

This means that Guide objects will apply their magnetic attraction already at quite a small dis-
tance when the zoom factor is below 100%. By contrast, Guide objects attract other objects at a
relatively great distance when for example the zoom factor is above 200%. The standard value
for the Snap to distance may be changed at any time.

Change Snap to Distance for Guide objects:

1. Choose the menu command Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences
(Mac).

2. Choose the Tab Pages & Objects.

3. Enter the value 20 in the field Snap to Distance. This means that magnetic objects will
already attract other objects when they are resized or moved and the distance between the
objects is less than 21 screen pixels.
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Summary Using Guide Objects
- Any object, regardless of its type or form, can be a Guide object.

- Guide objects can be created with the option Guide Object in the Object Settings dialog.

- Guide objects can be created as Guides by dragging them from the Ruler.

- Guide objects can be created automatically through the Grid option in the Document Setup
dialog in the menu File > Document Setup.

- Guide objects created through the Ruler or through the Grid option in the Document Setup
dialog are by default non-printable. This can however be modified by the user at any
time.

- Guide objects will be drawn like normal objects in front of other objects if the Grid option
in the Program Preferences dialog opened with the menu command Edit > Preferences
(Windows/Linux) or VivaDesigner > Preferences (Mac) was not changed to Behind.

- Any change in the hierarchy of Guide objects using the option Behind in the Preferences >
Program dialog will only be applied to newly created Guide objects and not to existing
ones.

- The “magnetic” snap property of Guide objects can be enabled and disabled with the
menu command View > Guide Objects Magnetic.

- The Snap to Distance setting specifies the screen pixel range in which the Guide object will
“attract” objects.

- The Snap to Distance setting is defined in the Objects tab in the Preferences > Pages & Objects
dialog, menu command Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences
(Mac). This setting is independent of the magnification factor chosen.

- Guide objects can either be selectable or non-selectable. This can be specified with the
menu command View > Guide Objects selectable. The shortcut keys for this command are
Ctrl + Alt + Shift + G (Windows/Linux) or Command + Alt + Shift + G (Mac).

- Guide objects can be hidden or shown with the menu command View > Show Guide Objects.
The shortcut keys for this command are Ctrl + Alt + G (Windows/Linux) or Command +
Option + G (Mac).
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Working with Alias Objects

Creating Alias objects

In the section Create objects, we noted that is a difference between original and Alias objects.
Since an Alias object is a copy of an original object, there is no Alias without an original. To
create an Alias object, select an object on your document page and choose the menu command
Object > Alias > Create Alias or use the appropriate shortcut keys. The object you select may be
an Alias object itself, which saves you time trying to find the original object, which could well
be on another page.

Create an Alias object:

1. Choose one of the following options:

- Create a new object of any type.

- Select an existing object.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + x (multiplication) or Ctrl + Shift + * (Windows/Linux) or
Command + * (Mac).

- Choose the menu command Object > Alias > Create Alias.

An Alias object will now appear below and to the right of the original object. The original
object will be deselected and the newly created Alias object will be selected. The settings for
the horizontal and vertical offset from the original object are defined in the Pages & Objects
section of the Preferences and are the same as those used for pasting objects.

3. Now select the original object and make some changes to it, such as fill or frame color/
shade/opacity. The Alias object you have created takee over the changes automatically.

Another way to create Alias objects is to use the options with the Duplicate and New Document
Page(s) commands. These commands not only allow you to create Alias objects on the same
page but also on other pages.

Duplicate objects as Alias objects onto following pages:

1. Create a document with two or more pages.

2. Create an object of your choice on the first page of the document.

3. Duplicate the object using the command Duplicate as described in the section Duplicate
objects:

- Choose the number of duplicates according to the number of follwing pages in the docu-
ment, i.e. if your document has two pages, create only one duplicate.

- Choose the Alias option.

- Choose Duplicate on Following Page(s) and Left and Right Pages. One duplicate will be
placed on each following page.

4. Click OK to confirm your definition.
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Duplicate objects as Alias objects by inserting pages:

1. Create a document with one page.

2. Create an object of your choice on the (first) page of the document.

3. Add one or more document pages to the document:

- Choose the command Document > Create Pages > New Document Page(s).

- Click the page in the Page palette and select the command New Document Page(s) in the
Context menu.

4. Click the checkbox Take over Objects at the top right of the dialog.

5. Choose the option Take over as an Alias:

- Choose the default option All Objects on Page if you want to create Alias objects of all the
objects on the first page.

- If you have several objects on the first page and only want to create Alias objects from
one object, select this object first and then in the dialog choose the option All Selected
Objects.

6. Click OK to confirm your definition.

A further method of creating Alias objects is to split a single object into identical sections using
the command Object > Split as described in the section Split objects.

In this chapter you have already been introduced to the features and behavior of objects. Many
commands can be applied to both original and Alias objects. There are also commands which
are exclusively applied to Alias objects and their connection with original objects. Through
these commands you are able to accomplish very complicated tasks.

Find Original

The original object has to be selected before any modification can take place. When there are
many Alias objects on different pages in a document, finding the original object may be hard.

This is where the Find Original command comes in.

Find Original:

1. Create a document with at least two pages.

2. Create an object of your choice.

3. Use the Duplicate command to create an Alias object on the following page(s).

4. Go to the following page. Select the Alias object and choose the command Object > Alias >
Find Original.

The program jumps to the original object and selects it automatically.

Obviously this function works just as well if all your objects are on one page, overlay one
another, and so on.
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Change Alias into a Copy

When using many objects you may feel the need to modify the content or appearance of an
Alias object directly, which can normally only be done through modifying the original object.
This can be done by converting the Alias to a copy of the original object, and then modifying
it. After the object is converted from an Alias to a copy it is not connected any more to the
original object, so it will not inherit any changes to the original object.

Change Alias into a Copy:

1. Create an object of your choice, and then create an Alias Object from it as described above.

2. Select the Alias object.

3. Choose the command Object > Alias > Change into a Copy. The appearance of the sizing
handles will change to show you that the object is now an original and can be modified
accordingly.

Flexible Alias Content

In the previous section the link between the original object and the Alias object was deleted by
changing the Alias into a copy of the object so as to be able to modify the content or the
appearance of this copy. When only the object content has to be modified and not the graphic
properties such as frame, fill, shade etc. there is an alternative to the Change into a Copy
command.

Especially for this purpose the program allows you to define that the original text or picture
object has a flexible content. If you then create an Alias of this object, the Alias object will still
inherit the graphic properties from the original object but unlike standard Alias objects it will
allow you to modify its content.

Create a Flexible Alias Text and/or Picture Object:

1. Create a text object and/or a picture object.

2. Choose one of the following options to open the Special Settings Object dialog:

- Press the shortcut keys or Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

- Choose the menu command Object > Special.

- Choose the command Special from the Context menu.

3. Click the checkbox Individual Alias Content and confirm with OK.

4. Create an Alias Object from each of the objects as previously described.

5. Check the success of your command by typing some text into the original OR the Alias text
object or by importing an image into the original OR the Alias picture object. If you now
change the graphic attributes of the original objects, these changes will still be taken over in
their respective Alias objects.

The same principle applies if you want to use the commands Duplicate or Split to create your
objects.
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Cancel the flexible content of an Alias Object:

1. Select an original object that has a Flexible Alias Object.

2. Choose one of the following options to open the Special Settings Object dialog:

- Press the shortcut keys or Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

- Choose the menu command Object > Special.

- Choose the command Special from the Context menu.

3. Click the checkbox Individual Alias Content off.

4. Click OK to confirm your command.

You will now see that the Alias Object has taken over the properties of the original and that its
content cannot be changed. You can change the setting back to individual content again at
any time, and then make content changes in the Alias object.

Summary Alias Objects
- Alias objects are virtual copies of their originals. All attributes including content (for text

and picture objects) are taken over in the Alias Objects.

- Alias Objects of Text or Picture Objects may have an individual content if the original
object has the option Individual Alias Content activated in the Special Settings dialog.

- Alias objects may be created

- manually using shortcut keys, menu or Context menu commands

- automatically with the Duplicate command

- automatically using the Split command

- automatically using the command New Document Page(s)

- Individual Alias Objects can be changed into a copy and thereafter edited.

- An Alias object can be a Guide object independently of the original object. Alias objects
inherit the Guide object status automatically if the original object is a Guide object. If an
original object with connected Alias objects is transformed into a Guide object, the Alias
objects will not inherit this property automatically.

- The command Find Original can be used to find the original object in larger documents.
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Object Grouping
The application allows you to Group a number of objects on one page. This is particularly help-
ful if a group of several different objects are to be treated as one object.

Create and recognize a Group

You can use the Group command whenever there are more than two objects selected. The
application also supports hierarchical grouping. This means a group may be part of another
group. There is no upper limit to the number of groups.

Create a Group:

1. Select at least two objects.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + G (Windows/Linux) or Command + G (Mac).

- Choose the menu command Object > Group.

A group has been created successfully when the selected objects are deselected and a rectan-
gular frame is shown around these objects.

Creating a Group Hierarchy:

1. Select both the group you created in the previous example and an additional object.

2. Choose one of the following options:

- Press the shortcut keys Ctrl + G (Windows/Linux) or Command + G (Mac).

- Choose the menu command Object > Group.

An Alias object can also be part of a group. Changes made to the original object will still be
inherited by the Alias object.

Create a Group with an Alias object:

1. Select at least two objects.

2. Create Alias objects of both objects and place them on the page below their original objects.

3. Select the first original object and the second Alias object.

4. Choose one of the following options:

- Press the shortcut keys Ctrl + G (Windows/Linux) or Command + G (Mac).

- Select the menu command Object > Group.

If the second original object in the upper row is selected and modified, the changes will of
course be reflected in the Alias object in the group. You can also create an Alias of a group.

Create Alias of a Group:

1. Select the group from the previous example.

2. Choose one of the following options:40
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- Press the shortcut keys Ctrl + x (multiplication) or Ctrl + Shift + * (Windows/Linux) or
Command + * (Mac).

- Choose the menu command Object > Alias > Create Alias.

REFERENCE
Section Working with Alias Objects

Select objects in a group

It frequently happens that you need to modify an object which is part of a group. You do not
need to ungroup the whole group first; you can select and edit single objects in the group
directly.

Select object in a group:

1. Select an object group.

2. Choose one of the following options to deactivate the group mode:

- Press the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

- Choose the menu command Object > Group Mode Active.

3. Select the desired object in the group and make some modifications to the attributes (e.g.
object size/position, fill color/density or frame color/density) as already described.

4. Choose one of the following options to reactivate the group mode:

- Press the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

- Choose the menu command Object > Group Mode Active.

Ungroup

This command enables you to disable the group feature and display the elements in their origi-
nal state. Since the program works with hierarchic groups, there may be groups within groups.
This hierarchy is retained when ungrouping. Therefore you may need to repeat the Ungroup
command several times to ungroup the group completely.

Ungroup:

1. Select the group.

2. Choose one of the following options to deactivate the group mode:

- Press the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

Note:
Please note that Alias objects are virtual copies of their original objects. If a group of grouped
objects which has a corresponding Alias group is ungrouped, the Alias group will completely
disappear since it can not be broken down into singular objects.
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Summary Object Grouping
- Objects can be grouped with the menu command Object > Group or by using the shortcut

keys Ctrl + G (Windows/Linux) or Command + G (Mac).

- Alias objects can be part of a group. The original object does not have to be part of that
group.

- Objects in a group may be edited individually without the group being ungrouped by
pressing the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

- The content of grouped objects can only be edited when the group mode is deactivated.

- Pressing the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac)
again reactivates the group mode.

- Groups are ungrouped with the menu command Object > Ungroup or by using the shortcut
keys Ctrl + U (Windows/Linux) or Command + U (Mac).

- An Alias object of a group of original objects will completely disappear if the original
objects are ungrouped. A Warning dialog will be displayed in this case.
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