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Introduction

You interact with the application through the creation of a new document or
the modification of an existing document. Therefore, after the application has
started, you will always create a new document, or open an existing document.
This chapter describes how the application interacts with documents.

Open Document
There are three ways to open existing documents. You can open a document with a double-
click on the document icon, or you can use the Open command in the File menu or the shortcut
keys.

When a document is opened through a double-click, the application is launched automatically,
and the document is opened.

When a document is opened from within the application, the VIVA dialog box will appear to
prompt you for the name of the file to be opened. This dialog also shows by default a preview
of the document if the document has been saved with the Page Preview options in the Pages
tab of the Pages & Objects section of the Preferences.

Open Document with Open command:

1. Choose one of the following options:

- Press the shortcut keys Ctrl + O (Windows/Linux) or Command + O (Mac).

- Select the menu command File > Open.

2. Choose the type of document in the pop-up menu Format if necessary.

3. Select a document in the dialog and click on the Open button.

During the opening of a document the application will display a progress bar which shows the
status of the opening operation.

The application also allows the opening of different documents from other applications
through special filters. These filters are provided by Viva and are subject to change. If error
messages are shown while opening a document, please contact Viva using the menu command
Help > Send a Message to Viva.
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Closing Documents
A document can be closed by clicking the close box, with the menu command File > Close or the
shortcut keys. .

Close a document with the close box:

Click the close box in the upper right (Windows/Linux) or left (Mac) corner of the document
window.

Close document with the Close command:

Choose one of the following options:

- Press the shortcut keys Ctrl + W (Windows/Linux) or Command + W (Mac).

- Select the menu command File > Close.

If you made any changes since you last saved the document a dialog box will appear prompting
you to save the document or cancel the command.

Revert to saved document
When you have made changes to an existing document which subsequently you do not want to
save, you can use one of the three following methods:

- You can undo all the changes you have made manually, insofar as you know which
changes you have made.

- You can close the document and when prompted to save the document choose the Don’t
Save option, and subsequently open the original document again.

- By far the easiest way is to use the menu command File > Revert to Saved or use the
appropriate shortcut keys Ctrl + Alt + Shift + Z (Windows/Linux) or Command + Option +
Shift + Z (Mac). This will accomplish at once all the steps mentioned in the previous
option.

Creating new documents
When creating a new document it is helpful to understand what kind of document you will
need to generate. It is always possible to make changes afterwards but it saves you time if you
choose the correct settings before you start working on a new document.

Create a new document:

Do one of the following:

- Press the shortcut keys Ctrl + N (Windows/Linux) or Command + N (Mac).

- Choose the menu command File > New.
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Once you have chosen the New command the Document Setup dialog box will open. This dialog
box allows you to enter specific options regarding the Page Size. The application enables you
to set the Page Layout and see the Page Preview, a preview of the Page Size and Page Layout
settings you have currently selected.

The Page Size and the Page Layout are the elementary ingredients of any document.

1. The Page Size definition consists of the Size, Orientation and Page Type. First choose the
page size:

- Choose a size from the Standard popup menu to select one of the default page sizes.
Once a selection is made in the popup menu the corresponding settings are activated.
The dimensions of the active standard page size are visible in the Custom Size entry field,
and these are editable once the Custom option is selected.

- To define or change the dimensions of a Custom page, activate the Custom option and
enter the appropriate values in the Width (W) and Height (H) fields.

2. Choose the Portrait or Landscape option from the popup menu Orientation.

3. Choose the option Single Pages or Facing Pages from the Page Type popup menu. It is
important to know which page type you want to have as this option cannot be changed
once the document has been created.

- When Single Page is selected in the Page Type popup, the entry fields Left and Right are
made available as Page Layout options.

- When the Facing Pages option is selected these entry fields will read Inner and Outer
respectively.

4. The Page Layout option in the application defines the part(s) of the page devoted to text.
Page layout consists of the text body, headers, footers, margins and annotations. This con-
cept has its roots in book production but is nowadays used for all types of publications. The
Page Layout is defined by the four distances from the page sides. When the Facing Pages
layout is used the application will automatically mirror the page layout.

- Lengthy lines of more than 40 characters are tiring to the eye and in general to be
avoided. For this purpose a page layout is often divided in two or more columns.

- When a choice is made regarding the amount of columns there is an essential difference
between a situation where it is necessary to get as much text as possible in a limited
amount of space, or a situation where the visual appeal of the layout is critical. The more
columns are used the less text is possible, the more freedom of form in the placement of
text, pictures or other graphic elements is possible. Whenever you need to design an
effective layout you are advised to consult the professional literature.

- You can define the layout by means of six entry fields and the two Page Layout options.
The Page Preview option gives immediate feedback about the choices made.

- The option Autom. Text Object defines whether or not a text object will be created auto-
matically on the first Alias page or first document page. The dimensions of the text
object will be calculated from the values entered in the Page Layout entry fields, and a
corresponding view will appear in the Page Preview section.

- The Grid option ensures whether or not the a grid of Guide objects will be created on the
first Alias or document page. These Guide objects are magnetic b< default.4
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- The entry fields Top, Bottom, Left and Right or respectively Inner and Outer define the
distance between the Automatic Text Object and/or the guide objects and the edges of
the page.

- The Column and Gutter entry fields define the number of columns and the distance
between them. The Page Preview shows the current settings.

5. If you already know in advance how many pages your document should have, then you can
make an entry in the Number field of the Insert Pages section.

6. Click OK to confirm the current settings.

- The application will now create a new document and automatically name it Untitled.
Documents created subsequently are automatically numbered consecutively to prevent
confusion.

- The document name can be assigned or changed at any time through the Save or Save As
commands.

- The size and orientation of the document and the Auto Text Box and grid settings in the
application can be changed at any time through the menu command File > Document
Setup.

- Be aware of the relationship between Alias Pages, the Auto Text Box and the Grid as
described in the chapter Working with Pages. The meaning of the Grid as a collection/
combination of Guide objects is described in the chapter Working with Objects.

Summary Document Creation:
- New documents are created by selecting the File > New command or with the shortcut keys.

- Essential for the creation of any document is the Page Size, which determines the dimen-
sions of the pages used in the document.

- Optional in the application is the Layout with a default text object (Autom Text Object)
and/or a magnetic Grid which allows objects to align with this grid automatically.
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Saving Documents
The application allows you to save documents in a number of ways. A distinction is made
between:

- Saving a new document

- Saving a modified document

- Saving a document under a different name

- Saving a document with a preview of the first page

- Saving a document with a preview of all pages

New documents are automatically named Untitled. Those which are subsequently created are
numbered consecutively. Documents are saved by selecting the Save and Save As commands
from the File menu or by using the shortcut keys. In either case the application will display a
dialog box in which you will be able to enter the document name and the location where you
want to save the document.

In addition, you can specify the document format. The application supports not only the VIVA
standard document format *desd but also the InDesign Markup Language *.idml and the VIVA
XML formats. Please refer to the relevant chapters of the manual for further information.

Finally, you can specify in the Document Preferences whether a preview of the first document
page or a preview of all the document pages is to be saved with the document.

Modified documents are saved through the menu command File > Save or with the appropriate
shortcut keys. The application will then save the document without prompting you for a docu-
ment name.

It may happen that you want to save a copy of your document with some small changes. In this
case you may use the menu command File > Save As or the corresponding shortcut keys. This
will save a copy of your current document under a new document name of your choice and the
newly saved document will remain open.

Save a new document:

1. Do one of the following:

- Press the shortcut keys Ctrl + S or Ctrl + Alt + S (Windows/Linux), or Command + S or Com-
mand + Option + S (Mac).

- Choose one of the commands Save or Save As in the File menu .

2. Enter the name for your new document and click OK.

Save a new document with Preview:

1. Choose the menu command Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences
(Mac).

2. Choose the section Pages & Objects and click the Pages tab.

3. Click both the checkboxes Save small preview and Save large preview.
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4. Choose the option All Pages or Manual. If you choose Manual, you must set the number of
page previews to be saved.

5. Click OK to confirm and close the Preferences dialog.

6. Do one of the following:

- Press the shortcut keys Ctrl + S or Ctrl + Alt + S (Windows/Linux), or Command + S or Com-
mand + Option + S (Mac).

- Choose one of the commands Save or Save As in the File menu .

7. Enter the name for your new document and click OK.

Save an existing document:

Do one of the following:

- Press the shortcut keys Ctrl + S (Windows/Linux), or Command + S (Mac).

- Choose the menu command File > Save.

Save a document with a different name:

1. Do one of the following:

- Press the shortcut keys Ctrl + Alt + S (Windows/Linux) or Command + Option + S (Mac).

- Choose the menu command File > Save As .

2. Enter the name for your new document and click OK.
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Document views
After starting the application and the creation of a new document a document window and
several application palettes will appear. In the chapter User Interface and other chapters, we
will describe the purpose and use of the different palettes. First of all we will describe the docu-
ment window, document views and document specific views. We will differentiate between
application and document specific views.

With application specific views we mean the appearance and position of the application pal-
ettes. By document specific views we mean the size and position of document windows such as
the active document view and the magnification factor.

Hide and show palettes

A palette can be hidden in three ways.

To hide a palette, click the close box , or select and click the appropriate item in the View menu
or press the keys assigned to that palette (if available).

To show a palette again, select and click the appropriate item in the View menu or press the
keys assigned to that palette (if available).

On Windows and Linux systems, the program provides a palette dock on the right hand side of
the program window. Generally palettes will be displayed in the dock as default. You may like
to have a number of palettes open in the dock, so an additional feature is to stack the palettes
over one another. In this case they will be shown as tabs and are easily selectable.

Note:
If your current document contains a Style Sheet operating with the same key combination
that has been assigned to a palette, then the palette activation and de-activation function of
this key will take precedence and the key combination will not work for the Style Sheet.

Selecting Open documents

Open documents can be selected either interactively or through the menu command.

To select a document interactively you click a document window. When you click outside the
document window or program window, you are automatically switched to the Explorer (Win-
dows/Linux) or the Finder (Mac) without quitting the application or closing any documents.
You can simply return to the application by clicking the document or program window once
again.

- When you are editing several documents at a time it is easy to lose track of a specific doc-
ument. For this purpose the application allows you to select a specific document through
the View menu. All open documents will be shown in the order in which they are opened.
The current document will be shown with a tick or checkmark before its name.

8



Working with Documents

Stack and Tile Windows (multiple documents)

Document windows can have very different dimensions. In order to manage multiple document
windows, you can use the Stack Windows or Tile Windows commands from the Window menu.

When using the Stack Windows command all documents will be shown behind each other with
a certain distance between them so that you can easily check the number of open documents.
This is the same as the Cascade command in other programs.

The Tile Windows command divides the documents as evenly as possible over the program
window (Windows/Linux) or the screen (Mac). If for example you have three documents open,
one document will take half the available space while the other two will share the other half,
taking each a quarter of the total space available.

You may find this less convenient, particularly for comparing, proofing or correcting docu-
ments. The program offers two further functions in the View > Window menu:

- Arrange Windows Horizontal

- Arrange Windows Vertical

The command Arrange Windows Horizontal stretches the document windows horizontally
across the available space above one another in a column form. The heights of the windows are
calculated exactly according to the space available.

The command Arrange Windows Vertical stretches the document windows vertically so that
their height corresponds to the vertical space available, and places them next to one another in
a row. The widths of the windows are calculated exactly according to the space available.

Tile a single document window

If the document you are working on has many pages, you may need to refer to different pages
for information while continuing to work on one page. One simple example is a manual with a
drawing or diagram on one page with numbered parts, while the text referring to those parts
runs over several pages. Switching back and forth between pages would be an irritating chore,
so the program provides two commands in the Window menu:

- Tile Document Window Horizontally

- Tile Document Window Vertically

The command Tile Document Window Horizontally splits the space available into two equal
parts next to each other, while the command Tile Document Window Vertically splits the space
available into two equal parts above one another. Please note the following points:

1. When you have tiled your document window, you can adjust the tiling proportion manually
by moving the mouse pointer over the Window splitter until it changes to the tile sizing
pointer and then with the mouse button held down drag the tiling barrier left/right or up/
down to suit your wishes.

2. You can move about the document and scroll between pages in both viewing sections.
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3. You can apply different zoom factors to the different sections.

4. You can apply a tiling command to a section (sub-tiling).

5. To cancel the tiling, choose the menu command Window > Cancel Tiling, close the document
or choose the menu command File > Revert to Saved.

Document zoom

The choice and use of a zoom factor for document viewing is an important part of your interac-
tion with the application. You can either zoom out to get an overview of the document or zoom
in to inspect smaller details.

The zoom factor is applied to the current document. The current zoom factor of a document will
be saved with the document settings, upon opening these will automatically apply. You can
apply a zoom between 1% and 1000%.

There are several ways to enter and change the zoom factor : the commands in the View menu
and their shortcut keys, the Zoom tool and the Zoom factor field in the Toolbar.

Through the zoom factors in the View menu it is possible to magnify the document view to
1000% or reduce it to 50%. The most commonly used scaling factors are also available through
shortcut keys. The advantage of using the shortcut keys is that the edit mode will not change.

Fit Page in Window is a special command. When this command is selected the current page is
resized to fit the screen. When the zoom factor is reduced you will get fully editable thumbnails
of the page(s) in your document.

Fit Spread in Window is a special command. When this command is selected the current spread
(generally two pages) is resized to fit the screen. When the zoom factor is reduced you will get
fully editable thumbnails of the pages in your document.

The next option to select a zoom factor is through the Zoom tool which you select from the
Toolbar. You can choose between the Zoom in and the Zoom out tools.

In order to zoom in on or out from a screen area, move to this area with . Simply click the
mouse to zoom in or out. To zoom in on a specific area, hold down the mouse button and drag
a rectangle. when you release the mouse button, the area selected with the rectangle will be
zoomed proportionally to fit the document window,

Another option for selecting a scaling factor is the Zoom factor field in the Toolbar. Through
this field the document zoom can be resized in 1% increments from 1% to 1000%.
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Select zoom scale through menu commands:

Select the appropriate Zoom factor from the View menu.

Zoom with Zoom tool:

1. Select the appropriate tool (Zoom in or Zoom out) in the Toolbar.

2. Hold down the mouse button and drag a rectangle over the area required.

Modify zoom factor with the Zoom factor field:

1. Do one of the following:

- Press the shortcut keys Ctrl + Alt + V (Windows/Linux) or Command + Option + V (Mac).

- Mark the Zoom factor manually with the mouse in the Zoom factor field of the Toolbar.

2. Enter the appropriate zoom scale factor and press the Tab, Return or Enter key .

Presentation Mode

The Presentation Mode offers a further possibility of displaying the document. While in the normal
layout mode the document window is shown, the Presentation Mode displays the document as
a page on the screen without window, palettes or menu. With this you can get an excellent pic-
ture of the optical effect of the document pages. You can also use the Presentation Mode to
create and show demonstrations.

Activate Presentation Mode:

Do one of the following:

- Press the shortcut keys Ctrl + 9 (Windows/Linux) or Command + 9 (Mac).

- Choose the menu command View > Presentation Mode.

The program will now center and display the current page on a black background. If there are
overlaps over the edge of the page they are automatically cut out, and Guides, but not Guide
Objects, are temporarily switched off. In this page display the program recognises the modes
Single Page or Facing Pages.

Leave Presentation Mode:

Click once with the mouse or press the Esc (Escape)key.

In Presentation Mode you can scroll through the pages using the arrow-up and arrow-down
keys and change the zoom factor with the plus or minus keys, or with the scroll wheel of your
mouse.
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