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Working with Tables

Working with Tables
A table is a collection and display of text, picture and graphic objects in the
form of rows, columns and cells. All horizontal cells are seen as rows, while all
vertical cells are seen as columns. Each cell may be (or may contain) a text,
picture, table or graphic object. The program offers extensive functions for
the creation, management and display of table objects. Below is a brief over-
view:

- A table can have any number of rows and columns.

- A table cell can contain text, an image, another table, a graphic object
or an object group.

- Table cells can be extended over several columns and rows.

- The widths and heights of all table columns and rows may be fixed or
variable. With variable values, the width and height are oriented on
the cell content.

- Table columns, rows and cells can have individual separator lines,
background colors and Style Sheets.

- A cell can have different indents on each side.

- Cell content can be rotated in 90 degree steps.
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Create Tables

Create a table object:

1. Choose the Table tool in the Toolbar.

2. Click at the position where the object should be displayed and hold down the mouse button.

3. Keeping the mouse button held down, drag the mouse in any direction.

4. Release the mouse button when the object has the required Width.

5. Define the number of columns and rows required in the Create Table dialog.

6. If default Character, Paragraph and Layout Style Sheets for the cells have already been created,
these may now be defined in the dialog.

7. Complete your settings by clicking OK.

The table will now be displayed with the number of columns and rows you have set. The follow-
ing default settings will be applied:

- The table height, which is displayed as a manual setting in the Module palette in Object or
Table mode, is automatic.

- The column width will be set to Manual. At the same time the program calculates the column
width so that all columns have the same width.

- The row height, which is displayed as a manual setting in the Module palette in Object or
Table mode, is also automatic. Here the program recognizes a minimum height for all rows
and calculates an initial height for the table object.

- The content of all cells is set as Text.

- All Text cells will be assigned Style Sheets as defined in the Create Table dialog.

- All rows, columns and cells are transparent and the table object has a frame.

- The separator lines between columns and rows are switched off.
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Selecting table rows, columns and cells
To select rows, columns and cells, you must activate the table mode.

Activate Table mode:

1. Move the mouse pointer over the table until the table pointer is displayed (a white cross).

2. Click the mouse button. When Table mode is activated,

- the Table menu will be displayed,

- the Module palette will switch to Table mode,

- the appropriate cell will be marked,

- bars will appear on the left and the top of the table object. The row numbers are dis-
played on the left, while the columns are assigned letters.

To activate the table mode for a table object that is part of a group, the group mode must be
deactivated, unless you want to ungroup the group.

Leave Table mode:

Choose one of the following options to leave Table mode:

- Click in an unselected cell.

- Position the mouse pointer on the object frame to select the table object and click the
mouse button when the graphic pointer appears.

- Click the object selection button (gray circle in the centre of the object showing a
graphic pointer).

- Hold down the Ctrl key (Windows/Linux) or Command key (Mac) and click the mouse
button with the mouse anywhere over the table surface.

- Click anywhere in the document window where there is no object.

Select a table cell:

1. Position the mouse pointer at the edge of the cell until the Table pointer (a white cross)
appears.

2. Click the mouse button.

3. If necessary, use the arrow keys to navigate to and select the required cell.

Select several table cells:

1. Activate Table mode as described above.

2. Choose one of the following options:

- Holding down the mouse button, drag the mouse over several connected table cells.

- Hold down the Shift key and click additional cells to select several connected or uncon-
nected cells.
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Select one or more table rows:

1. Activate Table mode.

2. Position the mouse pointer in the row bar on the left, so that the mouse pointer changes to
an arrow.

3. Choose one of the following options:

- Click the mouse button to select an individual row.

- Holding down the mouse button, drag the mouse over several rows that are connected to
each other.

- Hold down the Shift key and click additional rows to select several connected or uncon-
nected rows.

Select one or more table columns:

1. Activate Table mode.

2. Position the mouse pointer in the column bar at the top, so that the mouse pointer changes
to an arrow.

3. Choose one of the following options:

- Click the mouse button to select an individual column.

- Holding down the mouse button, drag the mouse over several columns that are con-
nected to each other.

- Hold down the Shift key and click additional columns to select several connected or
unconnected columns.

If during the selection you hold down the Shift key, you can select rows, columns and cells
simultaneously.

Table width and height, column width and row height

Table width

The width of the table object is determined by the sum of all column widths, plus a possible
line width for the object frame. It may be determined by a numeric or a percentage value.

Determine the width of a table with NUMERIC entries:

1. If you change the width of a table interactively with numeric width entries (sizing/selection
handles) or with the dialog, then the width of the columns will be adapted proportionally
(increased or decreased).

2. If however the table has at least one column with a percentage column width, the change in
the table width will only affect the columns with a percentage width. Columns with a fixed
width will retain their width.
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3. If in case 2 the table width is reduced to the point where it is less than the sum of the col-
umns with numeric widths (in this case all columns with a percentage column width have
already been reduced to a minimum), then the columns with numeric widths will also be
recuced proportionally.

Determine the width of a table with PERCENTAGE width entries:

1. The width of a table with a percentage width as a free-standing object is determined by the
layout.

2. The width of a table with a percentage width as a floating object in the text is determined
by the width of the text object, the object or layout column and the text attributes (indents,
etc.).

3. If you change the width of a table that has a percentage width interactively (selection/sizing
handles), it will change into a table with numerical width. The column widths will then
behave in exactly the same way as for a table with numerical width (see previous section).

Column width

Define the column width in a table (general):

1. You can set the column width to a fixed value, both interactively AND manually.

2. Interactive changes to a column width always take effect on the column to the left of the
cursor.

3. If you change the width of a percentage column interactively, this will be changed into a
manual column width automatically. For these the same rules apply as in the previous
example.

Define the column width in a table with NUMERICAL width:

1. If you change the column width interactively with the double-arrow tool in the HEADER of a
table, the change will affect the width of the column itself and also on the width of the
table, if the table has a fixed width and all its columns have fixed widths as well.

2. If you change the column width using the dialog, point 1 takes effect.

3. If you change the column width interactively with the double-arrow tool in the ROW of a
table, the change will affect only the left and right columns.The table width is retained in
ALL cases, irrelevant of whether the table has a fixed or percentage width.

4. If the table has at least one column with a percentage width, then width changes in the dia-
log take proportional effect only on the columns with a percentage width. Columns with a
fixed width and the table width remain unchanged.

Example:

Table width: 150 mm

Column 1: 100% (=50 mm)

Column 2: 50 mm

Column 3: 50 mm6
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- If the width of column 2 is changed interactively with the double-arrow tool in the column
HEADER, the relationship between columns 2 and 3 changes too: If the width of column 2 is
raised interactively to 80 mm the width of column 3 will be reduced to 20 mm.

- If the width of column 2 is changed manuallywith the dialog or the palette, the relation-
ship between columns 1 and 3 changes too: If the width of column 2 is raised to 80 mm, the
table width will be increased by 30 mm. The value "100%" in column 1 and the value "50
mm" in column 3 are retained.

- If all columns are set to a fixed width, the table width changes accordingly.

- If all columns are set to a percentage width, the table width is retained. The column widths
are shared equally.

Define the column width in a table with PERCENTAGE width:

1. In a table with PERCENTAGE width, changing the column width has NO influence on the table
width.

2. If the table only has columns with fixed widths, these entries will be changed to suit the per-
centage width of the table.

Example:

Table width: 100% (= 150 mm)

Column 1: 50 mm

Column 2: 50 mm

Column 3: 50 mm

Thus all values entered are automatically set to and displayed as 50 mm.

- If the width of column 1 is changed interactively, column 2 on its right will change accord-
ingly: If the width of column 1 is changed to 80 mm, the width of column 2 will reduce to
20 mm.

- The width of column 1 or 2 may be raised to a maximum of 99,002 mm (100 minus the mini-
mum width of 0.998 mm).

3. If the width of one or more columns is changed using the dialog, the program tries to sort
these entries according to the highest priority. The space left over will be applied on a per-
centage basis to the remaining columns.

Example:

Table width: 100% (= 150 mm)

Column 1: 50 mm

Column 2: 50 mm

Column 3: 50 mm

- If you enter a width of 100 mm for column 1, the entry will be reduced to 75 mm automatic-
ally. The entries for columns 2 and 3 will be reduced to 37,5 mm automatically.
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- If you enter a width of 200 mm for column 1, the entries for columns 2 and 3 will be
reduced to 25 mm automatically.

- If you enter a width of 90 mm for columns 1 AND 2, the entries for both columns will be
reduced automatically to 58.696 mm. The entry for column 3 will be reduce automatically
to 32.609 mm.

- If you enter a width of 30 mm for column 1, the entry will be increased to 34.615 mm auto-
matically. The entries for columns 2 and 3 will be increased to 57.692 mm automatically.

- If you enter a width of 30 mm for column 1 AND column 2, the entry will be increased to
40.909 mm automatically. The entry for column 3 will be reduce automatically to 68.182
mm.

- If you increase the width of column 1 to 100 mm, the widths of columns 2 and 3 will be
reduced to 25 mm.

- If you increase the width of column 1 to 200 mm, the widths of columns 2 and 3 will both
be reduced to the minimum width of 1 mm. All values entered that are above 148 mm (150
mm less 2x1 mm minimum width) will be displayed as 148 mm automatically.

- If you increase the widths of colums 1 AND 2 to 90 mm, the width of column 3 will be
reduced to the minimum width (e.g. 1 mm). All values entered that are above 74.5 mm (75
mm - (2 / 1 mm)) will be displayed as 74.5 mm automatically.

- If you reduce the width of column 1 to 30 mm, the widths of columns 2 and 3 will be
increased to 60 mm.

- If you reduce the widths of columns 1 AND 2 to 30 mm, the width of column 3 will increase
to 90 mm.

Example with different fixed widths:

Table width: 100% (= 150 mm)

Column 1: 60 mm

Column 2: 50 mm

Column 3: 40 mm

- If you enter a width of 100 mm for column 1, the entry will be reduced to 78,947 mm auto-
matically. The width of column 2 will be reduced proportionally to 39.474 mm and the
width of column 3 will be reduced proportionally to 31.579 mm.

- If you increase the width of column 1 to 100 mm, the width of column 2 will be reduced
proportionally to 27.777 mm and the width of column 3 will be reduced proportionally to
22.222 mm.
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Table height

The height of a table object is calculated from the sum of all row heights, plus a possible line
width for the object frame.

You can define the table height interactively with the object’s sizing handles, or numerically
with the dialog or palette. If you change the object height, the values for the row heights will
change automatically in proportion.

Row height

1. You can define the row height interactively with the double-arrow pointer or manually with
the dialog or palette.

2. The row height ALWAYS has a value. This value may have the suffix Exactly or Minimum.

3. Exactly means that the row height always remains the same and does not change. Rows with
the option Exactly have no minimum height and may also accept the value “0”. Cells of the
type Text with the option Exactly behave exactly like normal text objects, i.e. when too
much text is entered they show an overflow symbol.

4. Minimum (default value for all rows) means that the row height is calculated from the con-
tent of the highest cell, but in no case will go below the value defined. The actual height of a
row may therefore be greater than the value in the Row Height field! This is particularly true
if the Row Height value is smaller than the font size in one text cell in the row. It doesn’t
matter if there is text in the text cells. The height is determined by the font and the font size
selected. The height of a table object can therefore only be reduced to the point where at
least one line of text can be displayed in the text cells.

5. Changing the row height interactively always affects the row above the cursor. The action
only changes the value, not the suffix (Exactly or Minimum).

Editing table rows and columns

Defining row height and column width

You can define row height and column width interactively or using dialogs.

Define row height or column width interactively:

1. Activate Table mode.

2. Choose one of the following options:

- Position the mouse pointer on a column separator line in the column bar until the mouse
pointer changes into a double arrow.

- Position the mouse pointer on a column separator line in the column until the mouse
pointer changes into a double arrow.

- Position the mouse pointer on a row separator line in the row bar or in the row until the
mouse pointer changes into a double arrow.

3. Hold down the mouse button.9
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4. With the mouse button held down, drag the mouse in the required direction to increase or
reduce the row height or column width.

Note: If you change the column width with the mouse pointer in the column bar, the table
width will be changed at the same time. If you change the column width with the mouse
pointer in the column, only the column width will be changed and the table geometry will be
retained.

Define row height or column width numerically:

1. Activate Table mode.

2. Select a cell in the line or column that you want to change.

3. Choose one of the following options:

- Choose the menu command Table > Column and Row Settings.

- Choose the command Column and Row Settings in the Context menu.

- Choose the Column/Row tab in the Module palette.

4. Choose one of the following options in the fields Width (for columns) and/or Height (for
rows):

- Choose the option Manual and enter a value in the entry field if the column should be
given a fixed width.

- Choose the option Percent and enter a value in the entry field between 1% and 20.000% if
the column should be given a proportional width.

- Choose the option Exactly and enter a value in the entry field if the row should be given a
fixed height.

- Choose the option Minimum and enter a value in the entry field if the row should be
given a minimum height.

Notes for row height and column width
- The entries in the fields for row height and column width may be made manually, or you

can click the counter arrows up or down.
- All changes will result in an increase or decrease in the table object size.
- Through changes in the column width it may occur that columns are difficult to see. The

column width has a default minimum of 1mm. This ensures that the column is always vis-
ible and selectable. In this case you can either increase the size of the table object or
change the column settings, or of course delete the column.

- The row height has a default minimum which will be retained for every entry. This ensures
that the row is always visible and selectable.

- Percentage values must be calculated by the user. If for example the width of a table with
three columns should be shared on a basis of 3:1:1, the column widths must be entered as
respectively 60%, 20% and 20% respectively so that the sum of the three is 100%.
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Inserting/Adding rows and columns

You can insert single rows and columns in the middle of the table or add several rows at the
bottom or columns on the right.

Insert columns:

1. Activate Table mode.

2. Choose a column before or after which the new column(s) should be inserted.

3. Mark/select the whole column as previously described.

4. Choose one of the following options:

- Choose the menu command Table > Insert Column.

- Choose the command Insert Column in the Context menu.

5. Choose the number of columns to be inserted.

6. Choose the option Left or Right.

7. Choose one of the following options:

- Choose the option Expand Table Geometry to increase the width of the table object.

- Choose the option Keep Table Geometry (if possible) if the size of the table object sholu
not be increased unless absolutely necessary.

8. Click OK to complete your settings.

Insert rows:

1. Activate Table mode.

2. Choose a row before or after which the new row(s) should be inserted.

3. Mark/select the whole row as previously described.

4. Choose one of the following options:

- Choose the menu command Table > Insert Row.

- Choose the command Insert Row in the Context menu.

5. Choose the number of rows to be inserted.

6. Choose the option Before or After.

7. Choose one of the following options:

- Choose the option Expand Table Geometry to increase the size of the table object.

- Choose the option Keep Table Geometry (if possible) if the size of the table object sholu
not be increased unless absolutely necessary.

8. Click OK to complete your settings.

Note: If you choose the option Left (columns) or Before (rows), the new column(s) or row(s)
will take over the attributes of those marked. The alternative options create columns/rows
without attributes.11
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Add rows and/or columns on the right or bottom of the table:

1. Activate Table mode.

2. Choose one of the following options:

- Choose the menu command Table > Table Settings.

- Choose the command Table Settings in the Context menu.

- Choose the Table tab in the Module palette.

3. Increase the number of columns and/or rows. Confirm in the dialog by clicking OK.

Delete/Remove a column or row:

1. Activate Table mode.

2. Select the row or column to be deleted.

3. Choose one of the following options:

- Choose the menu command Table > Remove Row or Table > Remove Column.

- Choose the command Remove Row or Remove Column in the Context menu.

Delete/Remove rows and/or columns from the right or bottom of the table:

1. Activate Table mode.

2. Choose one of the following options:

- Choose the menu command Table > Table Settings.

- Choose the command Table Settings in the Context menu.

- Choose the Table tab in the Module palette.

3. Reduce the number of columns and/or rows. Confirm in the dialog by clicking OK.
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Editing table cells

Extend cells

You can extend cells into neghboring rows and columns to create one big cell. This option is
particularly helpful if for example you want to create table headers that stretch over several
columns.

Extend cells:

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

- Choose the menu command Table > Cell Settings.

- Choose the command Cell Settings in the Context menu.

- Choose the Cell tab in the Module palette.

4. In the fields Columns and Rows enter values to define by how many columns and/or rows
the cell should be extended. With this extension function the program recognizes all col-
umns to the right of and all rows below the selected cell. The maximum extension follows up
to the last column and/or row.

Merge cells

The function Merge cells presents another possibility for extending cells. You may already
know this function from MS-Excel or another table calculation program.

Merge cells:

1. Activate Table mode.

2. Mark several cells (at least two) in the row or column.

3. Choose one of the following options:

- Choose the menu command Table > Merge Cells.

- Choose the command Merge Cells in the Context menu.

Split merged cells:

1. Activate Table mode.

2. Mark the cells that have been merged.

3. Choose one of the following options:

- Choose the menu command Table > Split merged cells.

- Choose the command Split merged cells in the Context menu.

- Choose the Cell tab in the Module palette and reduce the number of columns or rows over
which the cell is extended to 1.13
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Note: The content of cells to the right or below the first cell will be set to None when they are
unmerged. Please see the section Cell content below.

Cell Indents

You can define indents for every cell in the table. This option is particularly helpful if you need
to define an offset between separator lines and cell content.

Define cell indents:

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

- Choose the menu command Table > Cell Settings.

- Choose the command Cell Settings in the Context menu.

- Choose the Cell tab in the Module palette.

4. In the Minimum Indents section, choose the options Left, Right, Top or Bottom and enter a
value as required for each side.

Cell content

In a newly created table the content of all cells is set to Text. These cells behave just like a sigle
text object. As with all objects you can change the content of a cell at any time. Thus a cell may
contain an image or even another table.

Define cell content:

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

- Choose the menu command Table > Cell Content.

- Choose the command Cell Content in the Context menu.

- Choose the Cell tab in the Module palette.

4. Choose one of the following options:

- Choose the option None if the cell should have no content. In cells of this type any
objects can be inserted.

- Choose the option Text if the cell should contain text. In a text cell you have all the
options that are available in a text object in Text mode.

- Choose the option Picture if the cell should contain an image. In a picture cell you have
all the options that are available in a picture object in Picture mode.

14



Working with Tables

- Choose the option Table if the cell should contain an additional table. For this table all
the settings in Table mode are valid, with the exception of the width and height, which
are based on the height and width of the cell.

Cell alignment

You can define a horizontal and vertical alignment for every cell. This option however only
takes effect on cells whose content option is None.

Define cell alignment:

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

- Choose the menu command Table > Cell Settings.

- Choose the command Cell Settings in the Context menu.

- Choose the Cell tab in the Module palette.

4. Choose one of the following options:

- In the Alignment section, choose the options Left, Center or Right to align the cell content
horizontally.

- In the Alignment section, choose the options Top, Center or Bottom to align the cell con-
tent vertically.

Define cell rotation:

1. Activate Table mode.

2. Select a text cell and type a few characters.

3. Choose one of the following options:

- Choose the menu command Table > Cell Settings.

- Choose the command Cell Settings in the Context menu.

- Choose the Cell tab in the Module palette.

4. Choose one of the options 0°, 90°, 180° or 270°.

5. Click OK to confirm.

6. Try the same option with a picture cell to rotate the picture.

Note: The picture rotation in the Module palette has no effect on a picture cell in a table. To
achieve an individual rotation, you must place a picture object in a cell with no content
(graphic) and set the desired rotation. This involves a lot of calculation which will slow down
the program quite dramatically, so where possible it should be avoided.
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Enter/import text in tables
When you have created your table to your requirements, you can start entering your text man-
ually in the cells. Please note that in the Preferences (Pages & Objects, Objects tab) the option
Use Tab Key to Navigate in Table is activated as default. This means that the entry of a tab will
cause the cursor to jump to the next available cell.

Navigation in Tables:

1. Make sure that the tab key option as described above is actually activated.

2. Click the first cell in the table.

3. Navigate in the table as follows:

- Press the Tab key to navigate forwards from left to right.

- Press the keys Shift + Tab to navigate backwards.

Type text into tables

You can type text into any text cell or group of cells. For this a single cell must be activated in
Text mode. Use the Tab and Shift + Tab keys for navigation between cells as described above. If
you fill a cell with text and continue typing, the row height and also the table object height will
increase automatically so that there is never a text overflow, PROVIDING the Row Height option
is set to Minimum.

Import text into tables

You can import text into any text cell or group of cells. For this a single cell must be activated
in Text mode, or several cells must be marked.

Import text into a cell:

1. Move the mouse over the cell so that the text pointer (I-Beam) is displayed.

2. Click the cell so that the cursor blinks in the cell.

3. Choose a suitable option to import a text file:

- Press the shortcut keys Strg + E (Windows/Linux) bzw. Befehl + E (Mac).

- Choose the menu command File > Import.

4. Choose a *.txt- or an *.rtf file from the dialog.

5. Click Open. The text will be imported into the cell.

Note: When you import *.txt files, the program will open the dialog Select Text Encoding. In
this dialog you can choose the encoding for the text file you want to import.
When you import *.rtf files whose text has various attributes, then these too will be imported
as far as is possible.
The row height and also the table object height will increase automatically accrding to the
text length so that there is never a text overflow, PROVIDING the Row Height option is set to
Minimum.
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You can import tab stop separated text in a table object in VivaDesigner using the Copy-Paste
process, so that columns and rows are filled, and even added to if necessary.

Import tab stop separated text:

1. Open the required file in in MS-Excel or in a text editor.

2. Mark the whole text and choose the command Copy.

3. Return to VivaDesigner and activate the Table mode as described above.

4. Select/mark the cell where the imported text will start. Alternatively, mark the cells to be
considered for the import, or mark all the cells in the table.

5. Import the copied text:

- Press the shortcut keys Ctrl + V (Windows/Linux) or Command + V (Mac).

- Choose the menu command Edit > Paste.

- Choose the command Paste in the Context menu.

6. Choose an option from each of the areas Merged Cells/Non-Text Content and Additional
Columns/Rows in the Import Tab Text dialog:

- Merge & Suppress Content / Beware Table – with this option you define that only sufficient
text will be imported to completely fill the table. All following text characters will be
suppressed. For this option all the cells should be marked.

- Merge & Suppress Content / Insert New Columns/Rows – with this option you define that
new columns and/or rows will be created in the table in order to import the complete
text. It may be that text copied from Excel or another table application will have an
additional row which must be removed manually from the table.

- Suppress Content / Beware Table – with this option you define that only sufficient text
will be imported to completely fill the table. All following text characters will be suppressed.

- Suppress Content / Insert New Columns/Rows – with this option you define that new col-
umns and/or rows will be created in the table in order to import the complete text. It
may be that text copied from Excel or another table application will have an additional
row which must be removed manually from the table.

- Keep Content / Beware Table – with this option you define that only sufficient text will be
imported to completely fill the table. All following text characters will be suppressed.

- Keep Content / Insert New Columns/Rows – with this option you define that new columns
and/or rows will be created in the table in order to import the complete text. It may be
that text copied from Excel or another table application will have an additional row
which must be removed manually from the table.
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Graphic attributes for Tables
Tables are objects and as such can be treated in the same way as any other other objects. This
means that they may have a frame and a fill color, which may also be a blend. You can set the
frame and the fill color in the Table tab of the Table Settings dialog, or in the Module palette in
Table mode or in the Object Settings dialog.

Colors for cells, rows and columns

The appearance of your table can be adapted according to taste and preference. Different col-
ors may be applied to cells, rows and columns as you like, but before you start adapting your
table, the following points must be considered:

- Row colors take precedence over column colors.

- Cell colors take precedence over row and column colors.

- If columns/rows are left with the default setting [White] + Transparent, any fill color and/or
shade that is applied to the table object will be visible in the transparent elements.

Separators

Separators may be applied to each individual cell or group of cells. You may well be familiar
with the separator/grid principle from Excel or other table calculation programs.

The graphic attributes of Separators are edited in the Separators tab of the Table Settings dia-
log or the Module palette in Table mode, and carry the same default settings as the object
frame for graphic objects or for line objects. The table frame is not included in the specifica-
tion, so if for example you select only the top left cell, the program will offer you the opportu-
nity to set a Right Separator and a Bottom Separator.

The most simple option is to create a table consisting of a grid wherby the Separators all take
the default option.

Create table with standard grid:

1. Create a table with several columns and rows.

2. Mark the whole table.

3. Do one of the following:

- Choose the menu command Table > Show Separators.

- Choose the command Show Separators in the Context menu.

The table will now be displayed with its grid. The Separators have the color [Black] and have
the default line width of 1 pt or 0.353 mm.
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Edit the grid:

1. Mark the whole table (all cells).

2. Choose one of the following options:

- Choose the menu command Table > Separator Settings.

- Choose the command Separator Settings in the Context menu.

- Choose the Separator tab in the Module palette.

3. Set the Separator options for the Horizontal Separator and the Vertical Separator.

Switch grid off:

1. Mark the whole table (all cells).

2. Choose one of the following options:

- Choose the menu command Table > Hide Separators.

- Choose the command Hide Separators in the Context menu.

Define Separators for individual cells, columns or rows:

1. Create a table with several columns and rows.

2. Mark the cell(s), row(s) or column(s) to which you want to apply a Separator.

3. Choose one of the following options:

- Choose the menu command Table > Separator Settings.

- Choose the command Separator Settings in the Context menu.

- Choose the Separators Tab in the Module palette.

4. Click the required Separator options to Yes and define the Left, Right, Top and Bottom Sepa-
rators and/or Horizontal Separator/Vertical Separator as available and according to your
requirements.

You may have decided to have the Vertical Separator in red and the Horizontal Separator in
black. Depending on your requirements, you can choose one of the options Horizontal Separa-
tor above or Vertical Separator above from the Table tab in the Table Settings dialog. The
option you choose defines which Separators will be output on top, i.e. above the others.
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Graphic Style Sheets for Tables
In Version 8 of VivaDesigner, you can also apply Style Sheets with graphic attributes to an
entire table, to rows and/or columns and to single cells. The rules regarding color priorities
apply to these Style Sheets as described above.

General information regarding the use of Style Sheets can be found in the chapter Working
with Style Sheets.

Create a Cell Style Sheet:

1. Choose one of the following options:

- Choose the menu command Edit >Style Sheets and select the option New.

- Press the shortcut keys Ctrl + Alt + Shift + S (Windows/Linux) or Command +Option Shift +
S (Mac) select the option New.

- Right click (secondary mouse button) in the Style Sheets Palette and choose the option
New in the context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined names
from the popup menu.

3. Select the Style Sheet Type:

- Select the option Table Cell.

4. Apply a fill color such as [Red] 100%.

5. Define all four Separators as [Black] 100% with a line width of 1mm.

6. Confirm by clicking OK.

Create a Row Style Sheet:

1. Choose one of the following options:

- Choose the menu command Edit/Style Sheets and select the option New.

- Press the shortcut keys Ctrl + Alt + Shift + S (Windows/Linux) or Command +Option Shift +
S (Mac) select the option New.

- Right click (secondary mouse button) in the Style Sheets Palette and choose the option
New in the context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined names
from the popup menu.

3. Select the Style Sheet Type:

- Select the option Table Row.

4. Apply a fill color such as [Green] 50%.

5. Confirm by clicking OK.
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Create a Column Style Sheet:

1. Choose one of the following options:

- Choose the menu command Edit/Style Sheets and select the option New.

- Press the shortcut keys Ctrl + Alt + Shift + S (Windows/Linux) or Command +Option Shift +
S (Mac) select the option New.

- Right click in the Style Sheets Palette and choose the option New in the context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined
names.

3. Select the Style Sheet Type:

- Select the option Table Column.

4. Apply a fill color such as [Blue] 50%.

5. Confirm by clicking OK.

Now you can create a table of your choice and apply the Style Sheets you have created to cells,
rows and columns to see the effects. You do not have to mark a whole row or column; if one cell
is activated and you apply a Row or Column Style sheet, then the whole row or column will be
assigned this Style Sheet.

Now create 3 more Column Style Sheets and 3 more Row Style sheets, each with a different fill
color. When you have done this, you can create a Table Style Sheet with header, footer, and
alternating columns or rows.

Create a Table Style Sheet with alternating columns:

1. Choose one of the following options:

- Choose the menu command Edit/Style Sheets and select the option New.

- Press the shortcut keys Ctrl + Alt + Shift + S (Windows/Linux) or Command +Option Shift +
S (Mac) select the option New.

- Right click in the Style Sheets Palette and choose the option New in the context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined
names.

3. Select the Style Sheet Type:

- Select the option Table.

4. Choose the options for the table object in the section Table Settings as required:

- For the Fill, set the Color, Shade and Blend Angle (if your fill color is a blend).

- For the Frame, set the Line Color, Line Shade, Line Style and Line Width.

- Choose the Separator Sequence: Vertical Separator above or Horizontal Separator above.

5. Choose the column options in the section Column Settings as required:

- Set the popup menu Left Columns to Yes and select one of your four Column Style Sheets.

- Set the popup menu Right Columns to Yes and select one of your four Column Style
Sheets.21
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- Set the popup menu Alternating Columns to Yes and select one of your four Column Style
Sheets for each alternating column.

6. Confirm your settings by clicking OK.

7. Create a table object with at least 6 columns, mark at least one cell and apply the table style
sheet.

Create a Table Style Sheet with alternating rows:

1. Create a new Table Style Sheet as described above.

2. Choose the row options in the section Row Settings as required:

- Set the popup menu Header to Yes and select one of your four Row Style Sheets.

- Set the popup menu Footer to Yes and select one of your four Row Style Sheets.

- Set the popup menu Alternating Rows to Yes and select one of your four Row Style Sheets
for each alternating row.

3. Confirm your settings by clicking OK.

4. Create a table object with at least 6 rows and apply the table style sheet to it.

Note: You can now apply the Cell Style Sheet created earlier to any cell or cell group in either
of the above tables to achieve individual effects. Try applying Separators with different col-
ors to different Row or Column Style Sheets.
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